Smoke Domain Edge Render Bug? (Miika 2.68.2 build)

To keep it simple:

Blender internal, all materials of objects changed to “shadow only”, receive transparent, domain has receive external shadows (material tab, Lighting), textutes has map to bounds.

All Internal materials were set by using “Oscurant Tools” and his override tools (because Cycles and internal on same object couses shadows only, to be like full mask or something).

All I want is to have render pass with smoke only, and shadows of this smoke. And that’s a challage…


(edit: in the circle on the left, you can see boder of domain/floor, the horizontal “gap” is another mask obj - it’s not a bug. On the right side, black curved thinggy, you see very simple mask of another car)

This is same animation render. No crash, no changes. From one frame, to the other: “pop”, floor visible.

I thought that was adaptive domain problem, but it’s not. Recalculated all - same thing.

Everytime when smoke reaches domain border: bam! sharp edge.

Domain is set to receive external shadows.

Scene is quite simple. Car inside domain as a colliding objects, floor, and wall.

I’m kinda in the dead end, probably my mind isn’t working properly right now. I’ve tried change light position - nothing. All lights are RayTraced (to cast shadows), and they are on layer with Smoke. All other objects are on other layers.

Camera is inside domain.

It’s probably someting I’ve missed, one parameter, but still… one render, and from frame to frame - it just poped out. And thats why I don’t know what to do.

If you need blend file, I’ll provide one.


Ok, fix for this was little tricky.

Main fix is based on Miika tip:

you can render the smoke domain using completely different object, right? It’s just matter of changing volume texture coordinates from “generated” to “object” -> smoke domain.

This, with making this obj bigger - fixed that problem. I hope at least :slight_smile: