smoke domain shadow

I’ve recently run into a problem. I have a scene with a guy holding a flamethrower. I have a smoke simulation set up for the flame effect. The domain is positioned at the nozzle of the flamethrower. Everything looks great exept the domain is casting a shadow on objects inside the domain (the light from lamps outside the domain doesn’t come through) and vice versa if lamp is inside the domain, it won`t lit th objects outside. AO and enviromental lighting further accents the effect. One solution i found is to scale the domain so it contains whole scene - the lighting issues are fixed, but the smoke sim is freaking huge now (because of scale of the object). As i cannot scale the domain manually in the edit mode, there is no other way to make it as big without changing object scale. Any advices? Now i think… in the future i would like the guy with flamer to move around, so the domain will have to be big, so maybe solution to the scale problem would be better.

You need to set “recieve transparent” on all the materials of objects that are inside the domain.

Thanks for the reply, but that’s not it. I have already set up recieve transparent on all materials.
I ended up making one big domain and putting whole scene inside - even the camera as the domain disorts everything (camera outside domain couldn`t render antialiased edges)… . The flame is still huge, but i managed to somehow tweak it, so it isn’t that horrible, but rather blurry rendertimes are insane.

This is an interesting Dilema, I have not seen this mentioned before. Perhaps you could put your flame thrower, etc in another layer without the domain and set lights to that layer only

Yeah i thought about trying to fiddle around with layers, i’ll see what i can do.

Ok, so i had everything set up so no frigging rendering problems would be noticable… large domain, everything inside, etc… . But somehow another huge issue emerges and it’s driving me nuts, because it’s ridiculous. When the camera is placed inside the domain, the fire will always be in the background - like on the images. So i cannot animate the camera to go through the fire. Any advices? I’ll attach the .blend
camera inside domain in front of the fire
camera view - flamethrower is behind teh fire(smoke)
render result… - blend file

I already tried to solve it with nodes - flames in separate render layer and then composited on top of everything, but this solution prevets me from having anything in front of the fire so i’d really appreciate any other solution.

hellooo there. :’)
i’m new and i wanted to say hello to all you lovely gamers. :’)
I found a good game,but I can’t play can play it?please help me!
pirate omen
I recommend pirate omen It’s fast to play, easy to learn,

I’m bumping into this problem as well. Are there any techniques to get rid of the domain’s shadow?

Strike that. Looking good with Receive Transparent and separating the layers.

Hello Duffator,

i have tried to render objects with transparency influenced by textures and noticed, that inside a smoke domain the texture has no influence and the object is rendered as solid.

Now to my solution: I enabled raytrace transparency for all materials which occur on objects inside the smoke domain. And voila, textures work again !
Hope this is related to your problem, but at least it is smoke domain rendering related.

I have 2 renders here, the second has additionally full oversampling enabled because the yellow propeller rims were a bit pixelated without, but inside the smoke domain ONLY.

On the first render you can see which propellers are inside the smoke domain and which are not, the second render shows no “domain borders”

Hope I could help, :wink: