Smoke is driving me crazy!

I really need some help with this… So I have a street scene and a motorcycle with some pipes. Inside these two pipes are two small spheres I am using as the flow object. I also made the pipes themselves a collision object. However, every time I press Alt A, I see the smoke follows the general path I want it to, but it encompasses the whole motorcycle! The smoke isn’t detailed either! I’ve tried increasing both the domain resolution and the smoke resolution, but nothing seems to work! I appreciate any feedback. This has been driving me nuts.

(ノ`Д´)ノ彡┻━┻

  1. The smoke collision is set within the smoke pysics, set to collision, instead of the physics set to the other collision physics:

  1. Are you sure you are changing the right settings? I cannot think of any other reason that you would not be able to increase the resolution. Here is a picture of what you need to increase (default is 32, but I set it to 64 in the image):

Have you looked at the Smoke High Resolution sittings?

https://docs.blender.org/manual/en/latest/physics/smoke/types/domain.html#id1


I would take a look at your substep setting. Also I am using a circle with normals facing out as opposed to a sphere and a wind effector with adaptive domain and seams to work fine even at a res of 64. Make sure you bake the physics as well before judging the way it is working as sometimes playing without baking can cause strange results. You can tak a look at the vid for any toher settings which shouldnt be much as I left most at default.

To all who answered:

First of all, THANK YOU FOR YOUR HELP!

Second, I do have the ground collision set within the smoke collision settings. And here is a picture of my domain settings.

I thought including some pictures may help, so here they are:

Here is my street scene. The highlighted box is the domain and the camera is at the cursor.

And here is a close up of my motorcycle. The highlighted spheres are the flow object.


If the bike is moving definitely put up you “substeps” to like 12 or higher.

can’t see all your settings, but the Initial Velocity etc might be something to look at. if your sphere is just set to be the emitter it will emit from all faces, inside the pipe too, which may cause issues. i’d be tempted to replace your sphere w/ a half sphere or plane facing outwards and set up a particle system for the smoke - after all, engine exhaust is coming out w/ some velocity, even when the engine is just idling.

Sorry for the late reply! I’ve tried toggling a bunch of settings, but either the smoke will fill the entire domain at once, the smoke will only emit for the first second, and the smoke will still encompass the entire bike.