Smoke not visible in render window (Blender 2.8)

I have found that smoke is not visible in render window even if it is visible in viewport.
Same problem is described here and here.
Smoke is visible in Image editor but not showing up when “Display mode” is set to “New window”.
CUDA settings (CPU/GPU) doesn’t make any change. Tested with Cycles.
I am using Blender 2.8b on Linux machine.
Anyone has this issue too?

Check Domain object.
Most of time, it is a unintentional mistake while making a manipulation on this object.

It may be disabled at render.
Its smoke modifier may be disabled.
Or its volumetric material may have been disabled.

I have experience the same. To fix it I basically just reset the animation to start from frame 0 again and it worked. It appears to be random, not sure exactly what is causing it.

It seems like just rendering in new window cause this. No objects changed at all. Animation played from 0 frame. Simulation baked and not baked. No smoke in new render window and smoke visible on Image view window render. Maybe when new render window is opened smoke simulation data are not taken into account?