Smoke rendering problem

My first attempt to smoke simulation failed. I followed a few tutorials and everything looks good till rendering, every time I get black screen, z-buf shows domain object in place but no smoke. I checked everything dozens of times and tried to tweak many parameters. Eventually I downloaded some other blender file with smoke simulation and rendering finished successfully even when I reorganized scene. I compared both files
but I cannot see any major differences between those 2 files.
Guys, do you see anything specific, any unwanted setup, or maybe blender got a bug?
I’m using 2.56beta.


Could be a bug… I’m not sure. It’s happened to me before too, what I did isn’t really a solution, but it fixed my problem. If it’s not too much of a hassle, start over. Or maybe you can append the objects and data from the old blend into the new one.

Thanks for reply. I tried one more scenario. I created two smoke scenes, one in 2.54 and the other in 2.56. This is my result.

  1. Scene 2.56 rendered in 2.56 - black screen.
  2. Scene 2.56 rendered in 2.54 - black screen.
  3. Scene 2.54 rendered in 2.54 - rendering ok.
  4. Scene 2.54 rendered in 2.56 - rendering ok.
    So the must be a bug in 2.56 or there is a specific configuration but on the other hand I checked everything many times.
    I think this is good point to report the problem to developers.

Before I report bug I need to double check it.
Can anybody spend 2 minutes and recreate basic smoke simulation in 2.56beta. Currently I am working on bloody 64-bit vista system.
Thanks a lot.

I’ve done tonnes (± 12) detailed smoke simulations these last few months for my art project, never once did I come upon this problem. It only happened to me in 2.54 once - so it’s most likely something you’ve done

Works fine for me, I just whipped up a quick smoke sim and it renders fine. I created it and tested it using 2.56a from I also loaded the file in a week old build from Both rendered fine. In the attached file, just bake the sim & render. 32-bit win xp here…



smoke_test.blend (679 KB)