Smoke scale changes between Window and Render - bug?

Hello,

I think the picture shows a problem I had with a project based on Miika’s Tutorial. The smoke (fire) has a different scale in the render.

It seems to be caused by creating a cube mesh as a domain and scaling it up in Edit Mode. When I created a new cube mesh, and scaled it in Object Mode the rendered smoke was scaled correctly.

This is weirdly similar in description to a bug with particle scale which I posted about (thanks to arexma for reporting it), but it can’t be the same problem. Is this a bug, or have I misunderstood something?

  • Al

That’s how the smoke simulation works - don’t scale the domain in edit mode, use object mode!

Is that documented anywhere? Searching these forums and google didn’t bring anything up and I only worked it out through trial and error.

Surely if the smoke appears different in the two displays that’s some kind of a bug? Perhaps a mesh should automatically revert to a cube primitive when set as a smoke domain to avoid this kind of confusion.

The info is like in every basic smoke sim tutorial out there (the fire ones usually are advanced and have basic knowledge of the smoke sim as a prerequisite).

The smoke appearing differently is not a bug since in the viewport you only see the voxels while the texture allows you to change the look…

I get that, but the difference between the viewport and the render doesn’t seem to be one of texturing. The voxels are clearly a different scale.

If this is just the way it works, then I perhaps it’s not a bug per se. But it is a very weird feature, and I can’t believe that the developers intend for situations like the one I described to occur.

Once I worked out the cause of the problem, it was easy to find the explanation. But it was difficult beforehand, because I didn’t know what to search for.