Smoke Simulation Not Rendering

Hi, I’m name is Beary

 Hi, I'm a relatively new to blender and I've recently been following a tutorial on how to make a explosion in blender. I used a smoke simulation to achieve the effect. In the tutorial, they use materials/textures to get the fiery part of the explosion done, and, midway, they render the animation, but when I try to, it doesn't show up.

Any suggestions on my this could happen would be greatly appreciated! :slight_smile:

                                                                                ~Beary

What tutorial ?
What renderer are you using
Blender version and your computer spec
If you are using the cycles renderer are you using cpu or gpu rendering ?
Please attache or supply a link to your .blend file for review.

-The tutorial was a blender guru tutorial (https://www.youtube.com/watch?v=mtSbZtPO_2w)
-I am using Blender render
-Blender Version 2.75
-Here are my PC specs:

–i5-4670k 3.4ghz 6mb cache
–asrock z87 extreme4 mobo
–8 gb ddr3 memory
–nvidia gtx 760 4 gb graphics card
–windows 7

Note that is a very old tutorial and some smoke/flames settings have changed since then.
Ensure you are following it to the letter.
As i previously requested

Please attach or supply a link to your .blend file for review.

Do a test

With the default scene select the cube
Under the Object / Quick Effects menu select Quick Smoke
Either in the toolshelf or F6 select the type of smoke sim (Smoke / Fire / Smoke + Fire)
Save your blend file
In the Physics panel under Smoke Cache bake the simulation.
Go to a suitable frame and render the scene

It should render correctly. Show us the result

Alright, here’s my original .blend and the rendered image of the test you told me to make. It seems to have worked.

Attachments


EXPLOSION.blend (1.09 MB)

Okay, I’ve thought up a theory:

In the video, he puts a material onto the domain object and sets its density to 0, explaining that if he didn’t put it at 0 it would render the entire cube, which is true, but in order for the smoke to still appear in the render, He makes a voxel data texture and sets the domain object to the cube, and then, I noticed there was an option just below the box to set the domain which(I’m assuming) is the source of the voxel data. In the older version of blender that he is using it’s default is set to “Density”, but in the newer version that I’m using, it isn’t even an option! Although I do not have a way to solve it I hope that you and/or someone you know can.


Ah, I figured it out. There was an option which was blank under the smoke domain’s material, I just had to play with it and it worked. Thanks for helping though! :slight_smile: