Smooth brush creates tension on some open borders

Hi. I was told to post this on the forums. Originally I made a bug report for it (http://developer.blender.org/T53132).

This describes a case where the Smooth brush, in Sculpt mode, collapses vertices on some open borders. Has this ever happened to you?

Smooth brush creates tension on some open borders

Description

On some open borders of a mesh the Smooth brush seems to add tension instead of the expected relaxation.
Here’s the Smooth brush being used on such an open border:

https://s1.postimg.org/3129i91q0v/smooth_Brush_tension.gif

This is the same mesh, with the open border selected in Edit mode and the Smooth Vertex operation being used a few times:

https://s1.postimg.org/4weuavesrz/smooth_Tool_smooth.gif

These are close-ups of the Smooth brush and Smooth Vertex scenarios above, respectively:

https://s1.postimg.org/1262rwx2kf/smooth_Brush_tension_close-up.png

https://s1.postimg.org/4sv8d5md7j/smooth_Tool_smooth_close-up.png

I always just assumed this was expected, unless it has thickness while your sculpting, plus having either dyntopo active or a multires in use. Is the desired effect the bottom photo? If so why even try to use the smooth brush?

modimist, have you tried using the smooth brush the way I described?

No, you didn’t provide a .blend so have no idea what settings you have, more importantly what version of blender you’re using. I do understand what your issue is though. Just saying it doesn’t seem like much of an issue is all. Good luck though, hope you find a solution! Curious to see if it gets resolved.

Of course. Here’s an example: Open Border Mesh.obj
If you’d like to try it, you can import this as a (Y forward, Z up) OBJ mesh. Make sure that you have the “Wavefront OBJ format” import-export addon turned on.

If you set it to Sculpt mode with the Smooth brush (S) and work on it, you should see this behaviour:

https://s1.postimg.org/9hp50lpr33/smooth_Brush_Tension_2.gif

User uvwxyz made an interesting point: