Smooth faces show artefacts

i REALLY need help on this one. comments are most welcome.
i generally model in Wings, and set up scenes and materials using Blender, since i find it easier to do most of my modeling in Wings. the problem i’m having right now is that there are some 32-segment cylinders in my model. setting the faces on the curved surface of the cylinder to smooth brings up artefacts (alternating light and dark faces) on the render.

i just want to create a highly reflective metal rod with sharp edges, but somehow, it’s not working. subdividing the cylinder so it has more faces doesn’t help either, and since i’m doing inorganic modeling, i don’t want to have to subsurf.

any help on the general thing on smooth/solid faces will be highly appreciated.

Have you tried recalculating the normals (Ctrl-N)?


Turn on Autosmooth in the Mesh panel.

thanks, will do as soon as i can get to work on my machine, and let everyone know just how i am coming along. thanks once again

Autosmooth should do the trick. If not, post a quick pic of the artefacts.

For me having the Unified Render on makes a difference.

duplicate faces can cause this also, try deleting all your vertices and adding a mesh cylinder. then try the render again.