Smooth Modifier in Blender 2.5

Im having a little trouble rendering the smooth modifier. Is it something Im doing wrong or is it just not up and running yet in 2.5?

I have a medium detail model that I wish to smooth and render. It has a mirror and a smooth modifier. It previews nicely enough in the 3d view, but doesnt render. As you can see from the faceted render on the right.

Is it something simple I’ve overlooked? thanks for your help.

the reason I didn’t use subsurf is because it deforms his shoulder straps in an undesireable manner.

The smooth modifier is not the same as smooth shading. The smooth shading button is in the Object Tools panel (T)
Also to ensure the modifier is applied during rendering, select the camera icon in the modifier settings.

Thanks Richard, I misunderstood the icons, I thought the modifier was active but it wasn’t!
I’m embarassed.
But in fairness, the two visual states of the Icon are differentiated but it is not clear which is active. Anyhow got the hang of it now. Thanks again.