Smooth shade help!

i seem to have some surfave issues after clicking on shade smooth?,it smooths out my curved edges, but it makes my flat edges look wierd.I took screenshots of my mesh, my normals, and things that i tried like selected the "bad’ faces and seleced mark sharp but it does not seem to work.

X(

You might need to tick the box for auto smooth if you haven’t tried it already.

Click on the Object Data tab, it’s the little triangle symbol, then click on Normals and check the Auto Smooth box.
You can also change angle to see if that helps.

The problem quickly and available options to fix it
https://blenderartists.org/t/distorted-faces-with-smooth-shading/1102261/7
The cause of the problem in more detail
https://blenderartists.org/t/new-modeler-struggling-with-booleans-and-clean-topology/1100924/4

Few things about posting:

Don’t waste everyone’s time when describing the problem. The problem description alone rarely gives answers, only a closer inspection and verifying the cause of the problem does that. The fastest and best way to post is to always include:

  • A full interface screenshots you use to help you write the description
  • An example .blend, which others use for troubleshooting and providing you visuals when they answer
  • Mention if you use 2.8, in case you skip the screenshots

Don’t write text into images. You’re not writing english correctly for one, and people can’t quote, do a search, or translate the text directly when it’s burned on an image.

i dont see all that in the little triangle though, is it because i am using 2.8 ? its not in the menu where i click on normals too.

This bit

1 Like

ah i found it, will give it a try again.

hi, erm im not sure why but all of a sudden my left mouse button is selecting the 3d cursor, and i have to hold shit + lmb to make normal selections. But if i open a new file it goes back to default. My preferences have not changed so i am clueless for the past hour trying to rivert back to how things were ? does any one know how to fix this ?

NES_controller_v3_wierd_cursor_issue.blend (764.0 KB)

You are in Set 3d cursor mode, change it back to select mode. (can use the w key to cycle selection mode)

2019-06-05_08-08

You have inverted normals (edit mode, select everything, F3 > recalculate normals) and a lot of ngons creating the smooth shading error.

1 Like

I had a look at the DPad. As @MadeWithFeet said, the normals were flipped for this object. Take a look at the attached version (you can Append it to your own file if you want to compare). You will see I changed where the faces were split in the area where the arrows are. I also inset a lot of faces which instantly fixed many of the shading issues. It still has the ngons, which means it would react horribly if you tried to add a Subdivision Surface modifier at any point.

D_Pad.blend (438.9 KB)

1 Like

hey guys, yea i flipped the normals because it actually looked better with smooth shade after flipping, and after a whole morning of reading all the pasted links, i tried auto smooth n weighted normals that magically fixed it.

hello, after the success of the smooth shade issue i started having some render issues, I will upload screenshots again to try and explain along with my blend file.

  1. I assigned colour and materals and adjusted lamp lighting and settings by the examples but my materials surfaces and colour asigned looked wierd. In A on the left, my base plastic remains white, and my red buttons dont look like they have the same plastic shine like shown on the right example.

  2. B:After deleting all materials and reassigning from scratch, i manage to get the beige gray colour but the red buttons still dont look the same. In the tutorial he even has to lower his speculars to make it not so shiny, but my red buttons n plastic + d-pad do not emit the same shine even if i turn up my specular or lighting.

  3. C:For some reason after awhile of retrying, when i make selections on my 3d view it show up on the rendered view above, before the render view only keeps updating the renders.

  4. D: I selected face that i would like to use a photo texture but hitting project from view did not duplicate my selected faces on to the image viewer, and the image texture shows up not on a flat plane and under the base material, and not just withing the selected faces as shown. ( I think for the step I must be missing a lot of procedures)
    NES_controller_material_and_texturing_issue.blend1 (822.5 KB)

hey dude, i tried to select and flip my normals to match your example but it still had some wierd shading effects may i know how you added those edge loops going across the arrows and inset my faces ?

Knife tool. From top view. K to activate followed by Z to cut through. Then Ctrl+X to get rid of the unwanted edges. To inset the faces I just selected them and pressed I.

1 Like

You are looking at the Image Editor top right. You need to change that to the UV Editor to see UVs overlaid on whatever image you want.

Cycles render view in 2.8 allows you to see overlays and do editing and stuff unlike 2.79. You can turn off overlays and gizmos and stuff and it will seem similar to 2.79 for that view.

You red buttons are reasonably shiny. I tried lighting it with an HDRI and it looks fine. The positioning of your lights may be off. You might have to move them around a bit to catch reflections.

You’ll have to Assign the faces on the body to the material that holds the decal.

1 Like

hmmmm ok il go back to rendering after i solve the surface issues XD i was unable to salvage my mesh despite fliping my normals to match yours so i decided to remodel it again with the new info that I have learned, i have reach the point wthere i cant seem to inset the borders of the arrow outwards like how you did it though. was it done with offset edges script ?

D-pad_redo_unable_inset.blend (152.1 KB)

I inset the face on which the arrow is (all of them at once that is plus the middle face)… As well as the faces that makes up the arrows themselves.

did u use the script to do it ? when i press “i” nothing happens just like before.

You haven’t selected the faces. You have selected some edges. The Inset command is called Inset Faces.

the smooth shading with auto smooth still doesnt work inside the arrows,…X(