Smooth shading error

Hello!

I was working on a model using blender 2.9 on windows 7, and as i was working, flat shading seemed to be working just fine but when i tried to use smooth shading immediately strange things started happening to how the shadows were being rendered.
i was originally using this model on a computer that had windows 10 and the smooth shading was working fine over there

i set the render pass to normal so you could see what is going on more clearly.

can you show us any more of the scene, material settings, etc?

That is what will happen most times with hard-edged objects and smooth shading…
Use Normal Auto-Smooth to fix it…( Note: Does not work on all things all the time )

1 Like

That’s not the normal auto smooth behavior, you can see what it does by plugging the normal into the color of you principaled bsdf, for example.

Since I don’t have or know what is in your scene…I just have the 3 cubes…and internal HDRI for shadow…
Render gets just about what you see in yours, though the geometry doesn’t look the same for instance…is that a hole with lights?
Basic shot with Normal pass…

and with Normal plugged into the Principled…screen view…

and with Flat, smoothed, and smoothed normal…