Smoothing out Edge loops

So, I’m making a helmet and I have used a good number of edge loops because I read that it is good practice when modeling. The problem is, when I subsurf it, I can definitely see that it is not smooth and kind of bumpy. Is there a solution to this? I am wondering if texturing/materialing will solve the problem on the finished product. Thanks!


Feel free to delete edge loops which do not directly shape object. Subsurf modifier will help later on.
In edit mode selected EDGE loops can be spread out using Smooth Vertex on T panel. Uncheck not needed axis and increase/decrease Numbers of times to smooth.

Yeah, you are using far too many edge loops. You only need as many edges as necessary to support the shape, no more than necessary. You have too many.

Just a unnecessary post, but if you don’t know, you can delete edge loops by dissolving them through the delete menu.