smoothing planar surface

I am modeling a terrain I imported from sketchup and I would like it looks smooth, in the center of the terrain an area has to be flat.
When I don’t smooth the terrain this place looks perfect but the surroundings are too sharp, but then, when I start to smooth the terrain this place becomes deformed. Is there a way to lock the vertices while smoothing the terrain? Or to reduce the number of faces on this planar place? Or should I wait the version 2.5? Here is how it looks:
brut picture



this is not smooth, this is subdivided
you cant subdiv anything, subdiv modeling is a complex modeling method
but you can try this: select sharp edges (see select menu) and set edge crease to hard

or use Edge Split modifiers, and set sharp edges

I take it you have a lot (!) of triangles in that mesh, at the end of that planar surface, or should I say the border you will have a lot of triangles meeting the rest of the mesh, what SDS (Sub-division-surfacing), Will do is to average between 3 or more points, In this case you will have 3 points being averaged between, which gives you pinches (sometimes they look like stretch marks), which seems to be what you are suffering from here, try to build your landscape, where ever possible out of quads, blender doesn’t Support Ngons yet either, so using the Fgons is a big “No No”

Here is something I was thinking when I read your post:

Landscapes such as the one you first created can suffer from any degree of irregular geometry. The intricacy of such a landscape could become a real retopological nightmare :slight_smile:

I just tried something in Blender, and it seemed to work quite well for landscapes that do not contain extreme vertical irregularities (assuming now you have your landscape mesh file open):

If you create a relatively high-poly manually-subdivided plane (i.e. enter Edit mode, select all vertices in plane, then subdivide several times), then scale and place the plane so that it hovers just over and covers your landscape mesh, you can then try the following:

Make the plane a Cloth by going to the Object Panel (F7 key) then selecting Physics. Under the Cloth tab, click the Cloth button.

Next, select your landscape mesh and set it up to detect Collision by clicking (under the Collision tab) the Collision button and setting Damping to 1.0.

Press ALT A to let the Cloth simulation begin to calculate.

Notice the frame at which the cloth seems to best cover your landscape and press the ESC key.

Manually move up to that frame using the Cursor Right key.

Select your subdivided plane.

Back in the Editing window (F9 key) go to the Modifier section. You should see a Cloth modifier listed. Click Apply.

If the end result turns out well, you can now use this mesh containing only quads in lieu of your original mesh :slight_smile:

For better results / more details, you might want to manually subdivide the plane one or more times as well as increase (slightly) the Quality level of the Cloth setting for the plane in the Cloth panel.

With higher subdivision and quality, a cloth simulation can take a while to process, but the end result could be worth it.

The newly created mesh could be substantially better for texturing as well as sculpting additional details in Blender.

Best of luck with your project!


@ RobertT

Clever boy :wink: