Smoothing trouble

I’ve been trying to smooth a model I made, but whenever I do I get this wierd darkening effect. Seemingly random streaks of the model just go black, sometimes along edges sometimes not. I’ve tried everything I can think of to fix this and even figure out whats causing it, and I tried looking up a solution, but nothing has worked so far. If anyone knows whats causing this and how to fix it, I’d appriciate the help. :slight_smile:

If you could attach the .blend file with the problem (or post a screenshot - Ctrl + F3 in Blender to take a screenshot) we could see exactly what the problem is. It could be one of a number of things, but I’m going to guess that some of your normals are the wrong way around. Every face has a normal which is simply a way of saying which way the face is pointing - which effects how it’s smoothed/rendered/etc.

TL;DR: Edit Mode > Select All (A) > Recalculate Normals (Ctrl + N)

To check if this is the case, if you go into Edit Mode and bring up the Properties bar (N) and scroll down to the Mesh Display section you’ll see that there is a Normals sub-section.

Push the second little button, the one showing a face highlighted, and this toggles the displaying of normals for faces. You can use the size slider to change the size that they’re displayed if they’re too big/small to see on your model.

So, now you can look at your model and see if any normals are pointing the wrong way. For any surface, all the normals should be pointing out of the same side. You can see in my cube that the normal on the left-hand face is the wrong way around, it should be pointing out of the surface.

The easiest way to fix this is to simply select all faces/vertices in your model (A) then in the Tool Shelf bar (T) go into the Mesh Tools section and down to the Normals sub-section and press Recalculate (Ctrl + N). For most models this will always put all your normals the right-way around. You can also manually select each face and press the Flip Direction button under the Recalculate Normals button.

Hopefully this solves your problem. If not, attach your .blend and someone can find the exact solution.

Just to rule out one other cause: select the object and change the shading from smooth to flat. Does the black on the faces disappear? I’ve run into this with the cycles glossy shader, and the solution involves adding faces that reduce the angle difference between a face that is visible and it’s neighboring faces obscured from the camera. I speculate that it’s caused by the normal at that location actually being calculated to point away from the camera by the smoothing algorithm. Then the glossy shader handles it poorly.

An example of what this particular cause of black faces looks like is in the final 20 seconds of this video tip as the subdivision surface modifier is briefly turned off:

You were right, when I checked the face normals there was an area along the edge of where the darkening was where all the faces were faced the wrong way. I don’t know how this happened, but I fixed it and my model looks just fine now. Thanks alot!