Smudging with transparent bitmaps

When I use a hemisphere light source (all others work fine) I get a smudging effect with parallel planes. (the background planes being just tinted glass, the foreground a somewhat transparent bitmap)

(image removed, see post below for a link)

Any ideas what causes this and how I can get this to work with hemisphere lighting?


If you could post a pic and give us info on your settings and geometry of the scene, it would be more easy for us to understand what is going on…

How about if you reduce the energy of the Hemi a bit???

my best guess is you are talking about that horizontal line on the two planes

are you using ray shadows on the hemi lamp? the hemi lamp points from every direction in a hemi (half) sphere, so I could expect it to have odd shadows.

Here’s a link to the image and a blend file.

The scene is simple:

  1. 1 light source at energy 120, moving it around doesn’t seem to make any difference.
  2. No radiosity, or shadows enabled.
  3. Not using unified renderer
  4. I played around with the lighting and relized that the problem happens with any type of light, not just a hemisphere light. You just have to move the light sources closer to the objects, which I hadn’t done)

Scene elements:

1 small plane of glass with an image texture, in addition to its glass material.
2 larger planes of glass using the same glass material as the small plane, without the additional image texture.
Camera views perpendicular to the the small plane in the foreground and the larger ones in the background.


Here’s what I’ve tried recently:

  1. Reducing light intensite, doesn’t remove the smudging, but makes it less intense.

  2. Set the no diffuse property on the light source properties, which did get rid of the smudging, but got rid of the material qualities. (no bitmap or color to the glass)

If this is a bug how do I report it?