SNAP Problems with VERTEX

Hi guys, I’m a beginner using Blender.

I’m following a tutorial but I’m meeting a problem with the Vertex Tool. I can’t snap an origin point of an image to a vertex of my dimensions cube.

You can see my video with the problem by https://imgur.com/a/tf5fzea

Thank you so much for your help.

I dont know if you are trolling here.

You activated the restriction by axis. In Front view you dont need to do this, just press g.

Why do you want to snap it? You can just move it a bit with g which is has nearly the same accuracy.

I’m not trolling, I can’t snap it while I’m using G. I tried without restriction it doesn’t work. It works with meshes but not with an image.

I want to snap it 'cause I want to rescale the image from the bottom left of my dimension box. Just want to have a perfect vertex snapping to do it properly.

Do you press the mouse wheel or something? I can clearly see that the axis are restricted.

Only g and move it

I’m trying it without pressing mouse wheel and it give me that : https://imgur.com/a/MqywbRx

Okay made a quick test. How have you shifted the origin of the image?

Snapping is working for me. The object you have is a plane?

I just drag and drop the image and use offset X and offset Y to move the anchor point. Then I tried to snap it.

Didnt know that works. And it didnt when i tried it. Only in another file… Weird

Anyway the snapping still works for me. Try adding a cube and test it with it since i dont know what you currently have there.

Uploading a file is faster if you want help. Without its guessing for me.

I still dont understand why you not just move the image to the position without snapping.

Did you try to switch to “Edge” to snap ?
Then try to snap twice in X and Y

And i would use “add image as plane” … to have a plane /mesh…

I think I’ll move it like you said but I like pixel perfect things. It works when it’s cubes but not and image and a cube.

Yes I tried but it doesn’t work too

What did you try ? With Edges or image as plane ?

I tried with Edge and i’m going to try with Plane

Possibly you have to activate via Add-Ons in the Preferences…

I’ve just done that. I tried with image as a plane but it works with render mode only.

I’ll try to drag and drop it with the addon active - DOESN’T WORK

Hmmm drag & drop ? :thinking:

When you add a new mesh (SHIFT+A) and then to → Image → Images as Plane the file explorer should openbed where you can select your image. Then you have a “real” plane…

Can you send a file we are getting nowhere here. Simple file with your problem.

Yep but to see the image i have to go to the render mode

Here it is : https://we.tl/t-nqUR7t1U6Q