Snowy Intro Clip (Work In Progress)

Hi all. I’m still quite a noob when it comes to Blender, and this work is by no means a complex or groundbreaking project (though I plan to make it more complex).

This is an early render of the intro film clip I’ll be using at the start of the video game I’m making. I produce my games under the auspices of Daedalus Films, hence the logo in the render.

I am not satisfied with the look of the snow particles (for one, every single snowflake is identical, all have eight points). I’ve been fiddling with attempts to randomize but OSA, Radiosity and Ray Shadow all need to be turned on for me to properly see certain aspects of what the render will turn out as. So it’s time consuming to wait to see the results of each change.

Also I plan on making the lamp-pole more textured, add some curlicued grooves, etc., basically just fancy it up some more than it is now. The round ball that serves as a lighbulb comes out as thick, textured glass, which is fine but it wasn’t my first choice. However, when I got the settings the way I wanted with it before, I ended up getting a weird fuzzy thick blue circle just right of center in every render. So I went this way with the lightbulb instead. Also the lamp-post is meant to be off-center in the…well, monument, I guess you could call it. Sign, monument, not sure what I’m calling the base of the ‘sign’ or whatever, but it’s not important.

Anyway, here’s a JPEG render of Frame 1 (attached image), as well as a very low-res .wmv of the animation (seven seconds in length, I rendered as a .mov file at 800 x 600 with full OSA, Radiosity and Ray Shadow, took over a day to render and the result was an 84MB .mov. Then using a crap program called Total Video Converter I converted the mov to a Divx .avi, before using the crap program Windows Movie Maker to take that .avi, add audio, and output the low-res .wmv that you can download now at the link below).

If it would help, I can put up the .blend file and a link to it. I am definitely at a point where I could use constructive criticism and teaching that will help make this work better in the long run. Thanks in advance. :slight_smile:

Rachel :slight_smile:

http://www.4shared.com/file/6798235/c55a0319/Snowy_Intro__Low-Res_WIP_.html

Attachments


Problems. The snow’s way too big, and also, why is it transparent? I’d make it just tiny little circles, if you want a halo turn on ‘shaded’ or you could make a tiny white circle mesh with a snowflake texture on it and turn off raytracing. You could also animate the snow-flakes paths to be more random with ‘random’ on and curve guides.

Of course,the alternative would be to get the new particle patch. Make an emitter, and set it to gravity -9.81, air drag to 1, and brownian motion to 30, which would basically mean the snow-flakes would drift and float and woosh about all of their own accord. Then you could make maybe ten little disks, all with different snowflake textures, and put them in a group, and set the emitter to randomly emit meshes from the group, so you’d have all different types of snowflakes. Also you could turn on spin, so the snow-flakes would tumble in the breeze. This would look much better and be far easier to do.

Hi BlackBoe, I have some follow-up questions re: implementing your suggestions that I trust you can help me with. I downloaded the new particle patch, which I see is basically the blender.exe which, when placed in the C:\Program Files\Blender Foundation\Blender folder, functions as Blender itself, albeit with additional features that aren’t in the standard Blender 2.42a program.

So, I have the patch. Question 1: You mentioned setting the gravity to -9.81. I can’t find the area for gravity settings - must be a noob thing on my part, but if you could show or tell me where specifically this setting can be altered I’d appreciate it.

Question 2: Possibly not having altered the gravity settings is why I’m having this second problem. Might also be that my single circular disk mesh is still too big. But I created on little disk to start with, just created a cube, deleted the four back verts so it was a flat square, added subsurf 2/2, and extruded it a bit so we have a small circular disk with a bit of depth to it. I also scaled it way down in size so that it would be a proper snowflake’s size (though again, it may be still too big). Before adding a texture to it, I wanted to see if I could get the particle emitter (a simple plane consisting of four faces above my ‘Daedalus Films’ sign and lamppost) to emit the circular disk mesh I’d created as the particles.

So I went to the third tab in the F7 Particles buttons, Particle Visuals, and in the settings in the top left of that tab, under Visualizations, I selected Object and typed in OB:Cube.005 (which is the name of my circular disk snowflake mesh which I want the particle emitter to emit).

Here now is a screencap of frame 24, I believe, as seen when pressing ALT + A KEY in Object Mode. As you can see, I’ve definitely messed it up somehow, since it would appear that particles are still falling down from the plane in a regular motion as I initially had in my first post in this thread, but they are no longer seen if I render, say, frame 50. What IS seen in a render (provided they are within the camera’s sight) is the particles that are made up of the circular disk mesh thing I made (OB:Cube.005). And they are flying all over the place and appear too large to me.

What I want to do is have particles falling down from the particle emitter (the plane above the sign and lamppost) as originally intended, but have the particles themselves be the circular mesh object Cube.005. Once done, I can fiddle with making them fall more randomly and swish around in the breeze, etc.

Bear in mind I really haven’t completed much tutorial work when it comes to particles, so if there are any specific tuts you can recommend that’ll help me out more in the long run, I’d appreciate it. Thanks as always for your time, and ditto to anyone else who posts here.

Fondly,

Rachel :slight_smile:

Attachments


That’s… odd. Can I see all of your particle settings together?

Actually, which version do you have? There’s two, and one goes a bit off the wall with brownian motion, if you don’t have 061123, that might be it, but if you do… Eh. I’d have to check.

Also, when I said ‘gravity’ sorry. You can set gravity by setting ‘AccZ’ (acceleration on the Z axis) to -9.81.

Thanks for your reply, BlackBoe. Sorry I wasn’t online much yesterday, my net access is temporary until the New Year.

Anyway, here - I’ve packed the data and uploaded the .blend file to the link below so you can see all the various settings. Before doing so, I did change the gravity to -9.81, and still had the same problem. Also, with Alt + A KEY, it seemd to go reeeeally slow after doing that. Lastly, yes, this .blend file was created in ‘blenderparticles061123.exe’ which I believe is the right one, not the brownian-goes-wonky one, right? Anyway, looking forward to your next post. Thanks, you’re a sweetheart.

Fondly,

Rachel :slight_smile:

http://www.4shared.com/file/6951383/4cfdd62b/messed_up_particles1.html

Oh oh oh ohhhhhhh… I know what you did. Look at your snowflake model. Though the mesh of the model is off-screen, select the snowflake and you’ll see the ‘center’ is way over in the middle of the scene, so while the snowflakes are actually in the right place, the model is way off to the side relative to the center. To center it, go–in the 3d view–Object(menu)>Transform> and then go ‘ObData to Center’ or ‘Center New’.

‘Obdata to Center’ will take all the mesh and move it so its ‘center of gravity’ aligns with the object’s center. ‘Center New’ does the opposite, lining up the object’s center with the actual ‘center of gravity’ of the mesh. Either of those will work, though with objdata to center you’ll have to move the object out of the way of the camera again after. Anyway, this should help.

Hi again everyone, especially BlackBoe. Alright, your advice definitely helped. I’ve attached a quick’n’dirty render of frame 69, and obviously this is still a work in progress. I know that if I take the time and effort, I can model a reasonably proper-looking snowflake mesh, as opposed to the lone circle-disk mesh seen in this render.

But I am more concerned about another aspect of this: how to get the particle emitter to emit a group of meshes instead of just the one object? In the area of the F7 particles buttons where I typed in (next to OB:) Cube.005 I seem to be offered the choice of only putting in a single object, not a group, as indicated by the OB:. (I, as you already know BlackBoe, am referring to the F7 particles buttons from the ‘blenderparticles061123.exe’ version of Blender 2.42a, which differ from the standard Blender 2.42a). It’s a bit of a pickle to me, so advice as always will be appreciated very much.

Fondly,

Rachel :slight_smile:

Attachments


Put all the meshes in a group of the same name, then change the particle visual to ‘group’ and put the group name in, and it’ll randomly select objects from the group.