Snowy Map Problem

Ok, im trying to create a snowy map, using the noise texture for the spec map, and a displacement map for the way the ground is, the problem is its only showing as white when I render GLSL, what am I doing wrong?

  1. If you’re trying to use the actual Noise plugin feature (in the Textures panel, next to Magic or Musgrave), it doesn’t work in the BGE. You can make a noise texture with GIMP easily, though.

  2. The displacement map also doesn’t work - you can only really go with the normal map. If you want it to appear bumpy, you could use the packaged Landscape add-on to make the snow bumpy, the way you want.

Oh ok, I see, so basically use gimp, make a noise map, then jadd it to it through textures that way, and then create a normal map (normal maps are the greyscale right?)
and ill look into the landscape add on thanks :smiley: will post a picture update soon :smiley:

Well, no, grayscale normal maps can’t be used directly with the BGE (or can’t be used efficiently - I think grayscale normal maps are bump-maps, which are supported, but they’re slower). There’s an included normal map filter in GIMP to convert a normal RGB image (your noise image) into a normal map version. It’s in Filters > Map > Normalmap, I believe.

Ive ran into a new problem, see picture below for detailed description but here is a summary for some odd reason, although I do not have the texture selected to change the diffuse color (and its a JPG file) the ground is see through…I dont understand why, or how?

Attachments


Hi, nice snow. I need to make some snow for my scene. Can you elaborate on how you made this or provide a sample .blend.

yeah sure, but havent you been doing this for years? I cant decide if you asking for this is a compliment or an insult ahah :smiley:
Im hoping compliment? (i suppose that just me being optimistic though)

Anyway, here is the snow.blend, and I figured out why it was see through and fixed it, but now I need to know how to get the stop point to stop clipping the texture T~T

its not letting me attach…
it keeps telling me failed…how to upload to mediafire?

Hi, if you can’t upload it you can zip the file and PM me. :slight_smile:

That clipping (the line of changing texture quality) is poor anisotropic filtering (I think). The latest Blender builds from BlenderArtists have anisotropic filtering settings in the User Preferences panel. Enable a higher quality filtering, and that should stop your clip-point.

Hi there, I’m curious to look at this too.
Is there a blend file attached some where (“Anyway, here is the snow.blend”)?
Thanks
M

P.S. Duh! I just read the part where you mention your troubles uploading. Sorry.
:o

lol ill try to re upload, maybe it will work today :D, and sure!

Edit: you werer right, the anistropic filtering sucked, changed to 16x and then lowered the normal map a little based on too much noise. fixed small problems with map, re uploaded :smiley:
still stating upload of file failed, does anyone know how Mediafire works?