So Ugly :)

When I narrow the Physics Panel, some buttons look so ugly. What kind of UI solution will work in this situation?



Horizontal buttons!? :stuck_out_tongue:

Narrow it a little further and you’ll see

well, you could edit the .blender/scripts/ui/ file and change the text of those buttons. some of them are way too long for any kind of in screen settings…


Thanks for the nice solutions. They’re all good. Especially, horizontal buttons is a real cure, but I am not accustomed to using it. I think I’m going to widen it again, and I hope there will be real Blender standard UI solution for this.

A 4k monitor

You’re right. My square LCD monitor is out of date IMHO. :no:

the buttons need simpler names with tooltips that provide the explanation like with everything else.
if you want to change it, just open up the .py file in the scripts folder and change the names to whatever you like.

don’t they go to a one column layout?

you must use 3dsmax: nice and clear GUI :slight_smile:

A better alternative (at least better than Endi’s solution :P) is to have names and abreviatures (or something shorter) The thing is to evaluate the width of the toolbar and in base of that the buttons should use the long names or the abreviature (Icons should also do a very good thing… but make icons is a science of it’s own, and we only have one icon designer ATM, AFAIK). Of course a way too small width will produce problems, but this is something expected, IMHO, and happens in any software that uses text inside buttons.

you can also zoom out.

Since it’s sort of the same subject, anyone else notice that if you put buttons (now called Properties) in the old fashioned horizontal layout, Blender be straight trippin? The panels flip out and hyperzoom all over for me.

I think you shouldn’t use Blender. Because it hasn’t got nice and clear GUI. :evilgrin:

Finally I have a temporary (or stable) solution?!. Short texts are so logical.

It is pretty obvisous however that the properties window only works vertically and is kind of designed to work vertically, it is completely horride when horizontal.

but I don’t care I prefer it vertical

Why don’t we have a settings that locks the panel width (or button width) to automatically adapt to the text length ?

ha ha ha! Just as funny as the first time i red this comments of yours. just the same… :stuck_out_tongue:

doesn’t it switch to a single column rather than two when the properties window narrows?

maybe an oversight here…

Personally I think the switch to single column comes a little late… but hey!

So, can we consider this as a bug? Single column doesn’t work with cache related panels.

billrey has just solved the problem. Thank you very much billrey! Cache panels are not ugly now in single columns. :smiley: