So what is the Blender 2.6x method for achieving IPO style control?

I just tried to import a very simple chain and sprocket model [built in 2.49b]. It is constrained so that rotating one gear spins every other gear and sprocket on the model. The chain is a double-link mesh that follows a curve, and moving along the Y axis spins the chain ~to match the sprocket. The chain uses an IPO driver to map the Z rotation of the gear to the Y location of the chain ~and it works great.
http://i271.photobucket.com/albums/jj125/Gizmojunk/Elevator_Gears.gif
Blender 2.64a seems unable import this by simply opening the Blend file. [WTH?]
So opening this in 2.64a breaks the functionality of the chain rotating in step with the sprockets.

Is there a method to do this ~this simply in 2.6x?

It can be done exactly the same way you described, the animation system just isn’t compatible between 2.4x and later versions. You’d just have to set up constraints again.

Thanks very much (I’m still new to Blender 2.6x). I will try to rebuild them; but I do not see any IPO interface… (Is it gone?)

If Blender 2.49b still has enough users, this is something IMO that Blender 2.6x should have [should have had] added to it; automated compatibility adjustment. If Blender 2.6x loads a 2.49 file, it should be able to extrapolate equivalent constraints ~or at the very least give a warning that the older constraint systems could not be mimicked.

I’m not 100% what is the IPO interface, but it might be the graph editor. and in the graph editor, you can change from F-Curve-mode to drivers.

Thank you; looking at it, this does appear to be the updated IPO interface.

What I’ve noticed is that Blender loaded the file with my IPO driver intact ~but non functional. What I mean is, the IPO driver used the value of a gear’s Z rotation, to change the chain’s Y location (causing it to spin around the sprockets).

Moving the object’s Y location value does not seem to give any visible result (!?), but moving it’s X or Z location certainly does. The chain won’t spin. :frowning:

http://i271.photobucket.com/albums/jj125/Gizmojunk/ChainYaxis.gif

This has drivers from on gear to another. graph editor / drivers


where it is purple I right click ad driver ( depends on what rotation you want)then go to graph editor it has become much more easy to do in 2.5+. I put averaged value add the driver here it is another wheel then world space. and below there I have it changed to -.5 cause it is a half sized wheel going opposite direction. I can post a blend if it will help.
This is a little blender icon machine I never finished.

That’s really cool and not something that I knew, thank you; but even so, this doesn’t seem to work for me. In my case, the gears are all moving fine, it is the chain that won’t move. In 2.49b, directly moving the “link” object along its Y axis would spin the chain [move it along the chain-curve]; in 2.64a, doing the exact same thing does not spin [or even move] the chain at all.

**But I notice that moving the Y rotation will rotate the links along the curve.

How does one cause an object to follow a curve in Blender 2.64a? I can do this easily in 2.49b, but something about the method appears to have changed in the new version.

Oh I put the conveyer belt on a lattice and rotated the belt with a driver…Ok I got it what ur doing Its curve deform no drivers it is different. ctrl a, to set rotation might do it… No that would not explain why its not moving on y at all…need to see the blend file.
here is a simple curve deform that works on x axis http://www.pasteall.org/blend/18467

That’s it, and yours works for me… but I don’t see what the essential difference is.

Here is the chain, if you want to look. https://docs.google.com/file/d/0B2XjRUIh021DM3BUaEUycnR6SmM/edit

Humm works in 2.49 but not 2.5 I skipped over 2.5 . Something about the curve deform, rotation needed to be different from 2.4 and 2.5 was one of the many reasons. I like using a lattice when I can, if it deforms ok and a rotation driver.

I think there was a bug with the curve, maybe it’s from the import. When I redrew the line, and added the curve deform, then moving the y axis worked.

here is the file.

gears-one_sided-for-264c.blend (606 KB)

hope it helps

Mathias.

Thank you @mathiasA

Hmmm… It get’s stranger now. When I opened your Blend and try to move the Y axis, nothing moves, so I have freshly loaded, then saved your Blend file for you to examine if you like. If it works for you then I presume that it’s unchanged, and that for some reason my install of 2.64a is mildly corrupt? If it doesn’t work for you then my install must have changed something when I saved it; but I touched nothing after loading, except to save the file under a new name.

Hmmm… When I uploaded this file, I see that it is 45kb larger than when I downloaded it from you… So something changed for simply saving the file.[WTH?] https://docs.google.com/open?id=0B2XjRUIh021DaXFNdE55aDUtb2M

I tried this again after loading the factory defaults. Load file, save file… File is now 57kb larger than it was when I opened it. https://docs.google.com/open?id=0B2XjRUIh021DUTlSYzdqXzU5YUE

I emailed this last file to myself through Yahoo (they virus scan attachments), it found nothing viral, so what could it be?

sorry, I didn’t know you wanted the y translation of the chain to be driving everything, I made everything to follow the rotation in Z of Sprocket. for the y on the chain I added a driver there, so you can remove it and you will be able to move the chain.

hope it make sens!

Mathias.

No it’s me that is sorry, I didn’t even think to look at the gear Z axis. The full model has several gears, but the Y on the Link object was what was transformed by the driver. Yeah, spinning the gear works well, thank you; but how exactly do I examine what you’ve setup?

My only option in the transform panel seems to be to delete the driver ~not modify it.

open the graph editor, then change the mode from f-curve editor to drivers, and make sure the window properties is open in the graph editor (N key) then you will see all the drivers and after selecting the different drivers on the left, you can modify them in the properties. The object driving is found in the variables and the amount of influence is the multiplication in the generator.

Thank you very much for this help; and it has helped too.

Do you know if Blender can auto-bake/set a key frame (every frame) from animation of the full gearbox for having just rotated the one (controlling) gear?

(I’d like to export the animation to FBX, but early attempt only import with just the one spinning gear.)

glad that it helps. To bake the animation, select your object, press the bar space and type “bake action”. then you can configure what you need. It should work.

:wink:

You said the information was imported but not active, Did you try the “F-Curve/Driver Version Fix” script to fix it?