So what's the deal with blender and ati?

Why does it still drop halfway in fps in the viewport after just a minute of running?, it’s beyond mildly annoying.

yeah its something to do with how Ati runs OpenGL that has always seemed to be a problem.

funny thing is i always buy Nvidia because of Blender, but ATI is supported by folding at home, and Nvidia is not. can’t win everything now can we.

Alltaken

Try these drivers:
http://www.omegadrivers.net/

I have on my computer some older Catalyst drivers and they work just fine. I’ve tried sometime ago other version of driver and encountered the same problem as you and I’ve reinstalled the version of driver that worked.

My advice: try the omega drivers I’ve pointed to you and if you find a version that works, keep that (and burn it on a “gold” CD)

Omegadrivers work really good, never had any problems with them, actually can’t remember last time I had Catalyst drivers.

Have tried both with normal drivers and with omega drivers, slows down on both my 9600pro at home and the 1800 card at work,

my tempfix so far has been to push P to launch the game engine and then esc back to reset the bug.

I have some older drivers that work with my 9700 pro, I can send them to you if you want to test but I think they will not work with your 1800 card (that’s newer that my driver CD).

Turn down your hardware acceleration is something that I’ve found works well for me,

LetterRip

same here… nvidia has always worked perfectly… and sounds way cooler too.

folding nowadays uses graphics cards too for processing?
…i’ve always thought about joining in to that… but never did, because my computer doesn’t idle really :slight_smile: when it’s on, it’s in use. when it’s not in use, i turn it off.

.b

Wasn’t there some tip posted somewhere about moving a certain atiXXX.dll to your Blender program directory to fix that? I don’t remember exactly, bit the laptop at the house used to do that UNTIL I moved/added that DLL.

This is for Windows only, though. Do a search here and at the other programmers forum and you might find it.

the trick is to install the openGL 1.1 softwaredriver microsoft releases for win95 in the blender directory.
the modern driver don’t emulate all the old function in opnGL1.1.

the link :
http://support.microsoft.com/kb/154877/en-us

I had the exact same problem. All I do is press P to go into the game engine, and then escape and the fps will go back up.

I guess this can’t be fixed until ATI fixes up their opengl. I’m still using ATI integrated graphics >.< Sooooooo… I might be getting a nice Nvidea for christmas. :smiley:

basse if you still want to get involved in [email protected] you should talk to your wife, and join the blender [email protected] team (folding washing at home that is)

Alltaken

blendermf, it’s hardly the most optimal sollution :stuck_out_tongue:

Check this out

http://blenderartists.org/forum/showthread?t=23281

I know it is not the best solution, it is very annoying at some times, and I wish it was fixed.