Soft bodies? Rigid bodies? Constraints?

(artistic_kelly) #1

I am working on a 6 second animation. The animation consists of two modelled dice and a camera at floor level. This is a “high hat” shot. I am only at the beginning stages of this, and I’m trying to get an overall idea as to workflow.

What I am attempting to do in the camera shot is to animate the falling of two dice, the camera tracks the dice. The dice fall to the floor and hit the floor and bounce with natural physics for the objects.

I have been working with Blender for about a year so I am well versed with the basics of the interface. What I am looking for are some suggestions as how to accomplish this task.

I am guessing it has something to do with soft bodies or rigid bodies and constraints.

Thanks for any help anybody can suggest.

0 Likes

(enhzflep) #2

Well, you can use the game engine to simulate the dice falling and bouncing then rolling after they strike the surface of the table. as long as you bake the result to IPOs, it’s there ready for a high quality render.

What I don’t know about yet is how to have them rolling and tumbling in the first place, other than let them roll off an inclined surface that’s out of view (or at least just cut from the final sequence)

A good place to start would be to have a look at the Rigid bodies tutorial @ http://wiki.blender.org/index.php/Manual/Rigid_Bodies

If it plays too slowly, you can hit f10 and change the MapNew figure & the fps.
If you want to make the animation happen in 1/2 the time, make the MapNew figure 1/2 of the MapOld figure & change the frs/sec to 1/2 of what it already is.
i.e 24frs/sec -> 12frs/sec.

0 Likes

(artistic_kelly) #3

I modelled a dice and created a plane for it to fall onto.
I set up the basic stuff for the dice, Logic->Actor->Dynamic->Rigid Body, Bounds/Box, Sensors, Actuators and Controllers

All looks good.

My problem now is that the camera I created to track the dice does not work properly. I start the GE simulation from side view to see if all works ok, and everything is ok.

But if I start the sim in Camera View, the view is arbitrary when the sim starts. Waaah…
What am I doing wrong?

Also…

I created my first dice to get things going. After setting everything up, I decided to Duplicate the object (Ctrl_D) and removed any of the duplicated settings. Because I want the standard two dice being rolled. Now the two objects just stick together, no matter where I place them in the scene when I start the sim. <scratches head>

Any help please. <insert big marilyn monroe kiss here>

0 Likes

(enhzflep) #4

How big? :stuck_out_tongue:

When I did it, I selected the camera then shift selected the die I wanted to track then hit Ctrl-T then chose TrackToConstraint. If I tried to parent either one to the the other first(camera->dice or dice->camera), things got a bit screwy.

I also found things went awry if I duplicated one cube from the other. Tried shift-D, they look okay in the game engine, but when back in the viewport there’s only one cube. :confused: Tried Ctrl-D, nothing happened. Tried Alt-D and I had the same result as with shift-D, looks okay in the game engine but there’s still only one cube in the normal viewport. :mad: If I run the game engine for a second time it becomes apparent that both cubes have taken up the same space & proceed to ‘explode’ apart from one another when the sim starts. :eek:

When I tried to work out how to go about it yesterday, I just created two cube primitives without duplicating one from the other. After reading your post just now, I had another idea - how about modeling a cube and saving that in it’s own .blend file. Then, just Append/Link in that cube twice - that way I could use the die from one of the beginners tutorials without having to model the blessed thing twice. Guess what? Works like a charm!!! - here’s a couple of frames.

Simon

Attachments


0 Likes