Soft body and Force field .... touch of modifier Confusion.


I did a trial run on a simple shockwave animation trying to learn some stuffs. Mostly, how tweaking things in the compositor changes stuffs. I noticed, after I did my test render that I forgot to tune up the rendering subdivide count. I do this with the animation playing in the 3d viewer and everything is fine. Out of curiosity … I clicked apply modifier, and all the physics stop working. I tried free all bakes then applying, same result. Going to fool around a bit more in a while and see if I can manage to bang the keys together till I get a spark. But hey, if anyone has a lighter in their pocket … I’m not against the help, even if it’s, “Hey, wrong rocks stupid.”:confused:

It works just fine with the modifiers … um … active(?) but not applied. This doesn’t make sense to me. But then, I’m not sure what does.

If the subsurf is above the simulation in the stack , and you change/apply it, you will have to re-bake the simulation.

With everything active but not applied and the simulation is at the top of the stack. The moment I apply either the displace or subsurf mods, it breaks. I tried freeing all bakes, then putting it back in the oven, but the bread comes out burnt. I tired the update all frames option too. I can change subsurf for view and the animation remains intact minus the frame rate changes. I’m am starting to wonder, could this be due to the fact that this is the file I reopened after I rendered the animation to an avi or something? lol

I can’t say that I’ve noticed before while running any frames but there is an orange bar at the bottom of the time line, so this is leading me to believe it has something to do with the old rendered stills or avi being used instead of … the new stuff?

To be clear, the animation goes from fluid to using (what appears to be) the same 1 frame throughout apparently. No more fluidity, just scaling up in size from start to finish of one still?

It could also be due to the fact of the size I’m guessing? But, it makes no sense to me that the preview (not the actual shift-z just 3d view object mode) would work just fine with the modifiers active … just not applied … but once applied nadda. I’m just going to render it with un-applied mods for now and see how it looks. This will drive me crazy not knowing what’s happening. I’ll have to open a new file and investigate.