soft shadows don't seem to work (area light)

I tweaked around about two hours but I simply can’t get nicely blurred, soft shadows. x and y samples, umbra, clip circle, dither, jitter, energy, gamma, - non of them have the slightest effect on my area light shadow, not even the size of the area light has. what ever I do: shadow sticks to it’s mean sharp edges.
Is there a basic thing I forgot? Maybe someone can help me out…

hoping: ulli

Im not a friend of that area light at all, because it’s not very easy to handle and it’s very slow.

Try that new Occlusion Lamp, there should be a CVS build with it. Otherwise, due to short rendering times, try to simulate soft lighting with buffer shadow lamps.



thanks ReSeT - meanwhile it works fine. but don’t ask me what was wrong. I simply restarted blender and it worked - as you say: with a significant increase of render time…

yes, it is not so easy to handle. But it comes closer to what I am familiar with in my job as a cameraman. And actually the handling of buffer shadow lights is even worst when you try to gain realistic soft shadows. I used to do this with a half sphere of some twenty spots. So for me area lights with dithered shadows are a real improvement - as long as they work.

What is this occlusion lamp thing you mentioned? Never heard of it but it seems to be interesting. Is it a new script or something?


ambient occlusion.

this is a technic with which you can calculate the distance between objects. the closer objetcs are like a sphere on a floor there more the area gets darker.

tip: build a mesh, build a cube, rotate the cube a bit so it touches with one edge the mesh, apply ao light ste samples to 6, enable ray and shadows and render.

you will see that the shadow below the cube is soft and gets darker to the inside!!!

ambient acclusion is a bit missleading here since ao manly is changing the color information of the ambient channel in terms of it is in darkness so it gets very dark and it is somewhat illuminated so it gets brithend up.
most time the ambient channel was used to birdthen up shadows but it was only bale to use one global value so wasing out shadows.

see reyes based renderer with those technic and there results.


I had a problem with the soft shadows as well. I think it was because the size value of the lamp was too small. Also it might make a difference if you don’t just resize the lamp with the s key, but change the actual size value in the lamp buttons.