Softbody, a bouncing cube or so ?

Hi,

i did not find any example with google, or they are just about cloth.

I’ve created a plane and a cube (subdivided several times) and let the cube fall down onto the plane.

If i set Goal to 0 (which means “just physics behaviour” to my understanding) the cube falls down and then is instable and all its vertices also fall to the plane.
The cube after that does not exist any more.

I just want a cube made of jelly or rubber that falls down, bounces a bit and then shakes a bit and then stays still.

Also using other objects (IcoSphere, not-subdivided-cube, …) does not help, they all fall down to the ground and behave as if they are made of weak cloth.

How can i create a bouncing ball or cube in 2.47?

Thanks for any hints,
Torsten.

Hi there,
this is my very first post and I am happy to be able to help somebody out.
I’m totaly new to blender and I’m looking at the “Noob to Pro” Wikibook at the moment.
My English skills are low, but I think if people want to, they can understand what I mean by what I’m writing.

Right now I’m at the Softbody topic in the Wikibook and I played with the settings quite awhile, because I wanted exactly that effect that you are asking for, tmohr. And I found no tutorial to do that too. I read alot about “play with the settings, 'cause that’s the best way to learn.” - right… :eyebrowlift2:

The only problem could be, that I’m using the latest Blender version 248.1, because I came to Blender after downloading YoFrankie!

Please keep in mind that this is done as I think balls should fall and everything is limited to my knowledge and small experience with Blender.

Well then, in the Soft Body settings, I turned “Use Goal” off. To keep the ball from be flattened, I raised the bending Stiffness.
It took quite some time for me to figure out how to prevent the ball from jumping 20 times until it came to rest. Finaly the Damping under “Soft Body and Cloth Interaction” for the Colision of the Plane did the trick.
Error Lim set to 0.2 speeded things up a little and the Speed is raised to have the animation duration below 50 frames.
Bending Stiffness, Mass and Gravitation had to be balance.

The Planesettings:
http://i12.photobucket.com/albums/a226/Moabiter/Plane.jpg

Ball settings 1:
http://i12.photobucket.com/albums/a226/Moabiter/Ball1.jpg

Ball settings 2:
http://i12.photobucket.com/albums/a226/Moabiter/Ball2.jpg

Uhm, here is the .blend file with the plane, the ball and a cube. ALT+AKEY ready.
Rapidsharelink (140kb)

It’s also realy funny to add Collision to the objects too and then let them fall on each other with a low Damping set.

Here’s the Noob to Pro wiki on Softbodys:
http://en.wikibooks.org/wiki/Blender_3D:_Noob_to_Pro/Soft_Body_Animation

I find this also very informative. And it looks like it shows the use of a previous Blender Build:
http://wiki.blender.org/index.php/BSoD/Physical_Simulation/Soft_Body

So far, I hope this is what you are looking for.
Teddl

Hey,

I did this once using cloth:
http://vimeo.com/927961

But normally you can do the same with softbodies.

Greetings
daniel

Hi there!
In v248.1 you should look at Damping settings in the Collision tab for the plane.
For the ball, under Soft Body look into Friction, Mass, Gravitation and Bending Stiffness.
Raising the Solver Error Limit to 0.2 speeds up things during testing. Lowering it again for the render might be a good idea.
I wonder why my first reaction on this was not posted.

A blend file without much wobbling

Iol, I’ve saved my first post. ^^

Hi there,
this is my very first post and I am happy to be able to help somebody out.
I’m totaly new to blender and I’m looking at the “Noob to Pro” Wikibook at the moment.
My English skills are low, but I think if people want to, they can understand what I mean by what I’m writing.

Right now I’m at the Softbody topic in the Wikibook and I played with the settings quite awhile, because I wanted exactly that effect that you are asking for, tmohr.
The only problem could be, that I’m using the latest Blender version 248.1, because I came to Blender after downloading YoFrankie!

Well then, in the Soft Body settings, I turned “Use Goal” off. To keep the ball from be flattened, I raised the bending Stiffness.

It took quite some time for me to figure out how to prevent the ball from jumping 20 times until it came to rest. Finaly the Damping under “Soft Body and Cloth Interaction” for the Colision of the Plane did the trick.

Error Lim set to 0.2 speeded things up a little.

Plane:
http://i12.photobucket.com/albums/a226/Moabiter/Plane.jpg
Ball 1:
http://i12.photobucket.com/albums/a226/Moabiter/Ball1.jpg
Ball 1.1:
http://i12.photobucket.com/albums/a226/Moabiter/Ball2.jpg

Result:
http://i12.photobucket.com/albums/a226/Moabiter/00032.gif
It’s also realy funny to add Collision to the objects too and then let them fall on each other with a low Damping set.

Here’s the Noob to Pro wiki on Softbodys:
http://en.wikibooks.org/wiki/Blender_3D:_Noob_to_Pro/Soft_Body_Animation
I find this also very informative. And it looks like it shows the use of a previous Blender Build:
http://wiki.blender.org/index.php/BSoD/Physical_Simulation/Soft_Body

you might also be able to do this with a Lattice.

by the way, this should be in the ‘support’ section