Softbody & other simulation baking speed up tips anyone??

Hi Guys,

As the title says anyone have tips on speeding up the baking process for softbody & other simulations?

I will admit I am using it on grass objects that were joined into one grass patch mesh. The individual grass strands themselves are low poly.

Select this mesh and turn on Softbody “freezes” Blender for a while before offering the settings. Then the same freeze happens when you enable the “eye” icon for soft body - Display modifier in realtime.

5 / 10 minutes later when over these freezes click the Bake all Dynamics and Blender starts the baking with the little black count box but eventually the gui goes all white - still counts up though but the bake takes hours.

So any tips? Or do we need to just suck it up - thats sim baking for you?

Machine Spec: Windows 8 Pro 64bit, 8GB Ram, i3 processor, 2GB GeForce GT630 Vid Card

Thats interesting.

I have just found a way to majorly speed up simulation baking. Here it is:

If you are using Windows 8 PC and have Blender 64 Bit installed, try downloading and installing a 32 bit build of Blender instead. The speed difference is phenomenal … relatively.

No more pre bake freezes / waits as you enable / disable SoftBody or enable / disable “Display modifier in realtime”.

The bake process way faster.

So - conclusion … Im really not sure …

Over to ye!

Physics baking has nothing to do with your render engine at all. You’re baking mesh properties, not rendering an image. There is no reason you should expect different performance with either render engine selected, because it isn’t using the render engine if it isn’t rendering anything.

Thanks K Horseman,

Yes, believe it or not I was aware of this but somewhere in the caverns of my mind I managed to associate the render engine with the simulation baking in the OP Title & text. I have adjusted that now.

I suppose more to the point what can be adjusted in the mesh properties and the like to speed up the bake? Any settings in the simulation settings themselves that would speed things up?

Reduce everything in the UI to only the essentials needed for the bake. If subsurf or other geometry-generating modifiers are not needed for the bake, turn them off. If collision is not needed, disable it. Use the lowest-density mesh possible (fewest number of vertices) – excess geometry is a drag on the sim. Don’t use Bake for static particle systems, only if some dynamics are needed. Use children when possible, and make them invisible when baking – only the parents actually get baked.

The Blender freezes noted are due to the app doing some major gnarly calculations for the sim. Duration depends on the complexity of your setup – a dense field of grass with Particle Objects can take a fair amount of time to be processed. Add a few dozen trees with particle leaves, some fog effects, and you can really strain the CPU. Be happy you have generous RAM – if not, Blender just crashes. Oh, joy. The white screen is caused by Blender not refreshing the graphics during the bake process – all resources are devoted to the bake alone. Annoying but generally harmless as long as the black frame counter is still progressing. Above all cultivate patience.

BTW, in my experience, if you disable the sim modifier for preview in the UI (e.g., Cloth or Softbody) the sim does not actually bake – it goes through the count real fast because no calculations are being made.

Thanks for the advice chipmasque - appreciate that.

YES, I noticed that and was wondering why that was the case. You disable the sim modifier for preview in the UI and the bake will not happen. If it did bake while preview disabled in UI it would sort most of this I would imagine, plus give more resources to the bake?

A bit of advice I got elsewhere was to try a recent Nvidia Beta Driver to sort these issues on Windows 8 machines. It didnt work. In fact I have found the whole softbody thing very eratic in the way it bakes. It will either not bake and freeze blender, will bake in a reasonable time or bake taking a very long time. Each time you try takes different lengths of time to finish a bake.

Maybe its because of my grass clump complexity - 14k faces. If I drop the amount of grass down to way less faces their aint much grass left. Each grass piece has 112 faces - made up of shoots and blades:



From my testing it would appear softbody is fine for low poly meshes, increase the faces and it effectively is unuseable?

Sorry, double post … deleted