Solid and texture modes display nothing

Hi. Recently the graphics card on my Gentoo GNU/Linux PC died, and so I had to switch to on-board graphics. Now, suddenly Blender (2.60) seems to be crippled in this respect: When I am wire frame mode, I can see the objects as expected, but when I switch to solid or textured mode, they disappear! I can still see the cursor and the object handlers, and even manipulate the objects, but they are invisible.

Given the circumstances, I naturally suspect some OpenGL or graphics driver problem on my system, but I was hoping to get some more information from Blender about precisely what is wrong. (E.g., glxgears runs fine.) The debug ouput, within the program and from the console (even with -d) does not seem to provide any relevant data. I also tried running with -noglsl, and that didn’t change anything.

So, is there some relevant settings in Blender somewhere that I should tweak or be aware of? I looked through the user preferences but nothing stuck out at me.

Update graphics drivers
Try changing the window draw method in the File / User Preferences / System panel.

I’ve got the same issue, running Fedora 16, with onboard Intel G41 graphics chipset. Wireframe shows OK,but solid or textured shows nothing,
I’ve tried all the different window draw methods with no apparent change.
Current vid driver version according to yum is : xorg-x11-drv-intel.x86_64 2.17.0-8.fc16
No updates showing as yet.