Solid black lines where meshes intersect / Artifacts of all kinds

Does anybody have any ideas why I would be getting these very thick black outlines where my rock intersects with the ground. Never seen this before - and it doesn’t seem to be affecting the rock on the left, which is an instance of the others.

I’ve tinkered with ambient occlusion settings and moved things around, but nothing seems to change anything.

Blender 2.92 - most recent nightly build.

Thanks

No answer to the above (anybody!!?), but clearly there are other issues that I’ve noted since, including the artifacts on other rocks. As can be seen below, they all look fine in viewport shading (top image) but look terrible in the rendered image (note, the rendered image has a few more rocks from a particle system).

I have tried:

  • adding subsurf modifier - no effect;
  • altering the shadow termination offset - no effect;
  • changing the normal and displacement strengths (and removing them from the respective shaders) - no effect
  • messing around with my sky texture and HDRI - all no effect.
  • messed around with AO settings - no effect.

Quite frustrating!

This was rendered using GPU - OptiX on Blender 2.92 - recent nightly build (have tried CUDA, doesn’t alter anythng). The rocks are all relatively low poly from Megascans.

Any suggestions would be gratefully received.

Give us a blend file so we can see.

1 Like

The blend file for this project is huge and not very well optimized. I thought I would try to replicate the problem in a smaller file, with just the offending rocks, a ground plane and the same world settings. However, in all other projects the rocks are absolutely fine and the problem can’t be replicated.

So it must be something wrong with this project in particular. It obviously isn’t a setting I’ve got wrong or the meshes. I’ll carry on investigating and/or start afresh with a nice clean project.

Thanks for replying.

If possible do that. It might help others in the future if we resolve this here in this thread. At least if it’s a bug a bug report would help the devs.

I know you say the blend file is huge, but it might be worth trying this as long as it doesn’t bring your computer to its knees. Open a second instance of Blender, delete the cube and other stuff. Go to the first instance of Blender, select everything and do a Ctrl+C. Go to the new instance and do a Ctrl+V.

It seems baffling for it not to be related somehow to AO

How far are the rocks, in world space, from the world origin? How far, in world units, do the rocks protrude above the ground?

A long way in ‘real world’ units which - perhaps stupidly (?) - I’ve been working in. It is a very large landscape I’m working on… However, you’re obviously on to something because I just moved a couple of the offending rocks to 0,0,0 and they render perfectly!

I assume its some super-noobish thing I’ve been doing? Is there anyway to fix without effectively starting again?

Many thanks for pointing me in this direction though. Very much appreciated!

They’re (probably) precision errors, in Cycles, when geometry gets far from the world origin. That’s why I was asking about position, scale.

Workarounds can be inconvenient, but if you move your focus objects nearer the world origin, you can fix the issue. If a single still, just select all and move it. If working on an animation, might be good to create an empty, parent everything that exists at root level to it, and then move the empty. Worst case scenario, like animation + physics, would involve some baking.

If Eevee, I haven’t seen the same precision errors. It seems to do everything it needs to do in camera space.

Just a thought, you could try to scale the units in the scene tab to 0.1 (or 0.01) and “trick” blender into thinking its not so far away from the origin.