Solidified (extruded) curve smoothing problem

Hello, guys!
I am quite a fresh Blender user trying to switch from Max. I really love Blender but sometimes I get completely stuck!

I am trying to import some curves (not only text) and use a Solidify modifier to add thickness and then bevel the hard edges. I also added a Decimate modifier for the Bevel not to destroy my mesh.

I turned out alright, but I don’t know how to smooth the resulted mesh.

The inner rim is not smooth even though I turned on Smooth in the Curve options. Is it not possible to have smooth normals while extruding from curve?

RMB->Shade Smooth

Thanks for the answer, unfortunately, that does not work.
It works fine after converting the curve to mesh, but if the geometry is a result of modifiers applied to the curve the “shade smooth” option does nothing. :frowning:

Any other ideas?

Blender handles curves quite well and it’s a pity that at some point I have to give up nondestructive workflow because of something that simple and small.

Please, upload the blend.

This is an Imported SVG.

Oh! I see that you have used the geometry tab to extrude the curve!
Yes. It is smooth now. But it is either smooth or flat. No options to smooth based on an angle? :confused:

If you use modifiers it won’t smooth.

But thanks anyway! It works a bit better your way!
Thank you very much!

You can try the Edge Split Modifier.

YES! Perfect!
That is awesome!

Thank you so much for your support.