Solidify Modifier Bug?

Perhaps I’m missing something. Look at this image. It’s a plane with a bevel and solidify modifier. Notice the Solidify thickness is at 0.03’ (feet) for both objects. Why is one thicker that the other? Both have scale set to 1,1,1. Any help is appreciated. If it’s a bug, I’ll file it.

It looks like you might have accidentally scaled the plane in Z axis and applied the transform. Look at the dimensions in the Z axis.

It’s a plane. There is no dimension in the z-axis. When I add a solidify modifier, it creates the number in the z-axis.

Can you reproduce it with a new object? I tried and couldn’t, always looks the same. Was this mesh (wrong one) a new object or maybe you separated (P hotkey) it from a different mesh with some constraints on it? (limit scale for example).

What I meant was this might have happened in a way or another.

1 Like

Yes, it was a duplicate of the larger plane. There must be some data associated with it somewhere, I just don’t know where, or how to reset/delete it.

Reset the delta scale.

1 Like

OK. I found it. What is Delta scale and why is it used?
(thanks btw :slight_smile:

Chip, sometimes, things leave orphan data around, I’ve tripped over this a couple of times. Set your outliner to orphan data and see if any meshes are lying around without an object attached to them. I encountered this doing an insert for Kitops, the plug file kept showing an object which didn’t exist in my outliner, but when I went to orphan data, there it was.

1 Like

Turns out @ramboblender was correct, I had used the Delta transforms, which I understand are mostly for animating. I has mistaken it as a new feature for 2.8, but once I reset the Delta transforms, everything worked out fine.

Working on a new tutorial on Industrial Design non-destructive modeling with minimum geometry and the combination of the solidify modifier with delta transforms got me confused. Here’s a peek at the finished product…now I need to find a script that can turn on/off modifiers for a given object…

This is really simple, you can go

import bpy

for obj in bpy.context.selected_objects:
    for mod in bpy.data.objects[obj.name].modifiers :
        mod.show_viewport = False

Swap out show_viewport for show_render and False for True if you want to enable modifiers instead

If you need a toggle you can go

import bpy

for obj in bpy.context.selected_objects:
    for mod in bpy.data.objects[obj.name].modifiers:
        if mod.show_viewport == True:
            mod.show_viewport = False
        else:
            mod.show_viewport = True

This operates on selection but you can target a specific object, just remove line3, unindent and specify object name in for loop :

import bpy

for mod in bpy.data.objects["Cube"].modifiers:
    if mod.show_viewport == True:
        mod.show_viewport = False
    else:
        mod.show_viewport = True
1 Like

@Hadriscus
Wow! Thanks a ton :slight_smile: This will help in creating my free tutorial series on non-destructive parametric modeling for Industrial Designers. Is there a way to map this to the Q menu?

1 Like

You can use “modifier tools” addon.


It will give you these new options if you have at least 1 modifier on your object.
modifiers%20toggle
You can right click on “Viewport Vis” and add it to Quick Favorites or assign a new shortcut.

1 Like

As you know transferring the Keyframes to Delta keeps duplicated object live , we can move it do anything to it and it’ll still animate same as the original object.

We can do the same without Deltas but every time we have to apply the transforms so the duplicated object won’t move to the same location of the original at the beginning of the animation.

Probably you knew this but I’ll leave it here for posterity.

1 Like