Solidify modifier for 3d printing


I’m building a car’s rear light model to be printed in 3d. To get the exact 2 mm thickness, I use the solidify modifier that works overall quite well but leaves some problematic areas.

As you can see, there is some overlapping. The red line is how I want it to be.

  1. Do you know how 3d printers behave with this kind of a surface? The model should be filled with ABS.

  2. Even more important question: how could I avoid this from happening without doing everything in “the manual way”?

What are we supposed to be seeing in this vague screenshot, it could mean a thousand different things without any context. If possible please always supply an example blend file to review

Check face normals are all correct.
Try with even thickness enabled
Try increasing clamp value
Use vertex groups to vary the weighting of the solidify effect for different areas of the mesh
Apply the solidify modifier and just manually correct any errors

I’m sorry I left the screenshot quite messy. Here are some more clear ones:

I’d want to get rid of the holes shown on my first image as I don’t know how they effect on the final product.

  • All the normals should be fine
  • Increasing clamp value reduces the thickness, which definitely is not a good thing for 3d printing
  • Even thickness doesn’t seem to do actually anything
  • Vertex groups will also approach the subject by reducing thickness

Fixing it manually of course is possible but it means very much job as the model is made of around 90k faces. (175k triangles)

I am not sure why your model is ending up with holes. Is your base shape simple extrusion in Y out of 5 segment C shape edge? Try Remove Doubles.

If it’s because the solidify makes the thickness inside of the C shape, could try doing the opposite. Move the mesh along the normals inside (alt+S in face select mode), flip normals, and then solidify.