[SOLVED] After creating a new mesh... I can't see it to manipulate it...?? need help

I’m fairly new to blender, and am working on a scene that was going along quite well. Now when I type Shift A and select a new mesh, nothing is put in the 3D view. It does however, show up in type only at the top right sidebar panel list.

As a test, if I open a new file and create a mesh, it works. But I’ve done a lot of work on this project, and need to keep working on this started file.

As a work around, is there a way to make a mesh in a new file and copy/paste it into the working (buggy) file?

I’m using blender version 2.57, and I’m on a Mac OSX lion v10.7.3

Any help here would be greatly appreciated.


New objects are added at the location of the curser. If the curser is outside the view clip distance you won’t see any new objects added. Delete those invisible objects from the outliner window, re-centre the curser with Shift+C or Shift+S/curser to center and then add your objects again.

I used this tutorials to help me out when I was starting.

And David ward’s amongst many others.
Very helpful especially when starting out. Also you don’t mention it. But…
You want to switch to edit mode. (use the tab key) & in edit mode you can start to model your meshes.

Wow! --Richard, thanks so much for that info… I have no idea how I got the cursor so far off the page, but that worked and all my attempt to add mesh items also came into view so I can delete them.

Many thanks.