Solved: Alt + A won't work, and neither will Animate?

Hi There

I’m working on my Kungfu Cuby movie, and Often I press alt + A to see how the movements are going in real time. However, all of a sudden, it won’t work, it just doesn’t do anything at all when I press alt + A. So I’m just scrolling through the frames, but this doesn’t get a smooth feel. So I went to Animate what I’d done instead, but it just popped up with a grey render window, and did nothing!?!?

What have I done to cause this?

Help Me!

Cheers
Cuby

alt-a only works if the mouse cursor is in the 3d window.

alt-shift-a will work when the mouse is over any window

By “animate what you’ve done”, I assume you mean render to an animation with the Anim button? … If so, you need a camera and light(s) in the scene. Press NUMPAD-0 to view what your camera is seeing.

Mike

Thanks, but I’ve been doing all that. It renders fine, but refuses to animate, or just play back with alt + A?

The only other thing I can think of is to check the start, end frames on the Scene/Anim panel, although if it’s rendering ok, that’s probably not it. Otherwise either post some screen shots of your buttons / NLA editor or post the .blend file itself.

Mike

Cuby - this is going to sound wierd, but give it a go.

Sometimes, when I hold a modifier key (shift, ctrl, alt etc.) down for more that a few seconds it “locks” on. That is, the operating system assumes you want it held down. Don’t ask, I don’t know why!

Try tapping SHIFT then CTRL then ALT just once, then try alt+a again.

You never know, it might not just be me!

Thanks, for that, but here’s something that makes this story even more stranger…

ALT + A works in all my other blender files, as does the Animate button, but this stubborn little file reffuses to co-opperate.

Here’s a screen shot, don’t know if it will help you to help me, but here it is anyway…
http://homepages.ihug.co.nz/~john.dinah/screenshot.png

Cheers
Cuby

Hmmm. Not sure, but I do have another suggestion; In the header at, ironically, the bottom of the 3D window, there’s an icon on the right hand side. It looks like a picture button and if you click it it will draw the current 3D view in the render window

If you click it while holding CTRL, it will render your animation using the current view settings (as opposed to the render settings) to the file specified in the render file box. I find, especially with more complex scenes, that this is incredibly useful for working out timing and animation glitches as it displays at the correct speed instead of alt-A which sometimes has to play catch-up.

I think you’re going to have to post a blend. In the meantime, I follow a general process when debugging weird things like this.

Try saving this file with a new name and see if that works.
If not, use the new file for further testing.

  • Try deleting the last few NLA strips you added - TEST
    
  • Try deleting the last few Actions you created (I'm guessing at what you have in the animation) - TEST
    
  • Try deleting the existing armature, add a new armature with two bones, add a few frames of simple animation - TEST
    
  • ...and so on 
    

Ultimately what happens when doing this is that something starts working again (hopefully) then you’ve got a lead on where the problem lies. Then you just re-open this copy file (don’t save it after you’ve changed stuff) and start the process again but doing less before testing - eg, if deleting six NLA strips fixed the problem, try deleting them one-by-one then testing each time.

Without inside knowledge of your complete setup and workflow, it’s difficult to guess what the problem might be.

Oh, oh. Me again. Have you tried opening a fresh Blender and appending the whole scene?

Hey, couldn’t help but notice you have a higher number of start than your finish frame…
maybe that is why it won’t work.
I don’t recall being able to animate in reverse without flipping frame direction in the sequencer.
Check it - you have start as 830, and finish at 757.
Maybe I’m wrong…
Craigo

D’Oh! :eek:

Hands up who else didn’t notice that!

Undoubtedly that’s that’s the problem :slight_smile:

I logged it as a bug report, and hoepfully it will be fixed for 2.43 :smiley:

Mike

Hand goes up

Awesome! That completely sovled the problem! Thanks so much craigomatic! You saved me alot of frustration.

I wonder how I ended up with my end frame higher?

Anyway, thanks for all your help guys!

Cheers
Cuby

:eek: :rolleyes: :o :frowning: :cool: :stuck_out_tongue:

What else can I say?

:slight_smile: I am glad I could help - you are very welcome.
I observe as much as I can, and this time it worked.

You guys teach me something every day, so thank you!!!
:smiley:
Craigo