[solved]area 0 faces

hello

I have a problem after a retopo. I don’t know what happened but looks like I generated some area 0 face (or faces with less than 2 verts).

First of all I would like to know how this could happen… I did a retopo using a shrinkwrap modifier together with the snap function.

Second, is there any way to find and delete these problematic polygons?

Thanks!

You can’t have faces with less than 2 verts, that is just a vertex. Faces can have zero area if all its vertices are in exactly the same place.
First remove any double vertices by selecting all vertices (A) and W / remove doubles.
Then in edit mode and vertex or edge select mode use the Select / Loose Verts/Edges menu entry. Then delete and selected vertices.

Thank you for the help Richard.

Sorry, I meant with less than 3 verts, my mistake.
However I already tried the remove doubles command, but he cannot find any double verts. Regarding the select loose verts/edges command, I didn’t know that (so good you told me, is something new). I tried, but apparently he does not select anything. But if I click A after this looks like something was selected after all because he does not do select all, but everything remain unselected as if previously something was selected.

So i still didn’t manage to fix the problem. I uploaded the file so if you want you can have a look to it…
http://www.pasteall.org/blend/11574

thanks again! :wink:

Solved thanks to a hint from another forum.

There was something really odd in the file, which we didn’t understand how came out. However to solve the problem the solution is to select every vert using B. Imn this way overlapping verts will be selected only once. Now inverse selection and erase. Voilat! The bad faces are gone :slight_smile:

can you elaborate a little on this strange problem !

ok but how come when you delete doubles this does not work ?

what do you mean by overlapping verts ?
these are not double all verts seemed linked except for about 10 verts
but where are they ?

by selecting one vert and getting all linked verts you can see there are something like 10 verts which where not linked!

so what was the problem here ?

thanks

I told you I can’t exactly understand what happened. Im trying to figure it out, but I really can’t understand. For sure it’s strange they are not removed by removing doubles. Btw you have the blend some post up, so if you want to experiment you are welcome…

Is not that I don’t want to, I am trying but I can’t figure it out.

i did a small script to see if there was any verts with large location values and nothing there!

what you see if what you get in viewport
but there are something like hidden may be but what

i’ll experiment somemore to see what happen here

but did you try to report this as a bug may be and see what answer you get ?

thanks

It’s strange indeed.

I looked at the outliner :
http://i.imgur.com/UyFKo.jpg

If i select everything and press P -> By Loose Part to separate non linked part of the model, i obtain 2 additional models.
http://i.imgur.com/U7Pxe.jpg

That may be those vertices RickyBlender mentionned, hinting at them being possibly results of multiple extruded accidentally vertices, creating then those 2 additional objects not linked to the main model, but still if it was the case the remove double should have worked, though i don’t see them unless i Snap them to the Cursor, maybe they’re extremely far from the center of the viewport ?

Try to delete those additional objects from the outliner (right click on the 2 Circle.xxx that are not corresponding to the model and select “Delete”) and see if after doing that there are always “area 0” faces.

still strange

i made a script to list of verts greater then let say 50
and did not see any verts with large location on the main object ?

i don’t understand where these unlink verts are could not see these
even with dot keyboard !

so what’s going on here

is this a bug may be ?

thanks

They can be seen if you do the following :
-delete the mirror modifier so the strange vertices will not be duplicated in the other side of the symetry line
-select a vertice from the model, then press L to select all those linked
-press CTRL+I to invert so it select those strange vertices
-press SHIFT+S then “Selection to Cursor” to snap all those vertices to the 3D cursor.

This way you should see them there.

To see how they were linked into 2 objects , i selected them one by one then pressed G to move those vertices around
http://i.imgur.com/FlXIP.jpg

I wonder where they are if we can’t see them without snapping them to the 3D cursor

sorry i already tried that and it does not work for me !

only thing is if i b box then inverse i can see this


cannot get your little shapes you’v shown !

very strange

thanks

Yes I am starting to think it could be a bug, so it’s time to report it. I just wanted to have some feedback before…

well let us know what you get as an answer

i tested it in SVN 44020

it’s very strange !

ONE THING HERE

i did seperate things

ok and i get some circle that are at extreme distance look in N panel

did you add a circle far away in location ?

this can create some problems to view if not right scale i guess

problem is that i did not see any of these verts with the script i did
which is even stranger

saluations

did my script on this circle and get this for verts location

Object name = Circle.003

Verts List &&&&&&&&&&&&&&&&&&&&&&&&&&

Vert no : 0.00 X = 0.37 y = nan z = nan
Vert no : 1.00 X = 0.37 y = nan z = nan
Vert no : 2.00 X = 0.37 y = nan z = nan
Vert no : 3.00 X = 0.45 y = nan z = nan
Vert no : 4.00 X = 0.36 y = nan z = nan
Vert no : 5.00 X = 0.08 y = nan z = nan
Vert no : 6.00 X = 0.33 y = nan z = nan
Vert no : 7.00 X = 0.23 y = nan z = nan
Vert no : 8.00 X = 0.52 y = nan z = nan
Vert no : 9.00 X = 1.01 y = nan z = nan

End Verts list &&&&&&&&&&&&&&&&&&&&&&&&&&

very stange indeed

looks like a bug

salutations

sorry ive never done this… where do I submit a bug? Here? https://projects.blender.org/tracker/?func=browse&group_id=9&atid=498
Do I have to make an account?

when you open 2.6 at top help menu i think
there is an option for bur report

you may have to open up a new account for doing a bug report

salutations