SOLVED/blender 2.62 osx cuda NOT WORKING

osx problem solved with release-44377

since the 2.62 release me and other are encountering problems using cuda.

until 2.62 i could use cuda (experimental mode). now it gives me always:

“CUDA error: Invalid value in cuMemcpyHtoD(mem, host, size)
Abort trap: 6”

since i’m not the only one and i think it’s not normal behavior:

What has changed between 2.61 and 2.62 that causes this?

(own build and official, same) on macbook pro, osx 10.7.2, gt330m

placed a bug in the tracker…

Im having a similar issue on my system… NVidia 4600GTX 1gb, Win 7 x64

The Nvidia 330M supports CUDA 1.2
The Nvidia 4600 supports CUDA 1.0

Blender Cycles with CUDA requires the version 1.3 as minimum and suggest the use of a newer card supporting the 2.x shader model

http://wiki.blender.org/index.php/Doc:2.6/Manual/Render/Cycles/GPU_Rendering

basically your cards are very very old.

Similar issues here with my XP Po Blender 2.62. I have an NVidia GeForce 9500GT, supports CUDA ( NVIDIA Cuda 4.1.1 driver ):

http://www.nvidia.com/object/product_geforce_9500gt_us.html ( under specifications )

I have a 2.61 build where I get NONE - CUDA - OPEN CL available under User prefs / System / Compute Device. I can switch to Viewport Shading RENDERED with CUDA/Experimental enabled.

With 2.62 I get NONE - OPEN CL available under User prefs / System / Compute Device. No CUDA option.

Two different builds, same PC.

Aidan

please do not threat this as a bug, the Nvidia specifications are clear about this, also is the Blender wiki, your 9500GT only support the 1.1 version, so it’s not capable to deliver a full and correct experience with Blender Cycles.

ble,

When you say v1.1 I assume you are talking about OPEN CL: c version?? As opposed to Cuda Version?

If my card is too old why is it working no problem with my Blender 2.61 version right now?

Aidan

in your post you have cited CUDA and the topic is about CUDA.

Sorry Yes - wires crossed

Aidan

OK,

Its the COMPUTE CAPABILITY you are talking of so:

Yes you are right - my 9500GT only has compute capability value of 1.1

Seems like time for a new card

Aidan