[Solved] Blender segfaults on startup

Recently (and out of nowhere) my self-compiled version of blender and 2.48a from d.b.o segfault on startup.
It wasn’t caused by a certain revision, it just started crashing on startup.
I’m just curious if anyone has had this happen to them before and have a solution.
I’m using Ubuntu 8.10 32 bit.
Thanks…

P.S. - This should probably be in a support forum, but there isn’t really an appropriate one, so I put it here.
Feel free to move :slight_smile:

try running it trough the terminal and post the error here, also,
this should probably have been posted under the support forums,
but we all know this gets more views here, I suppose.

anyways I bet its to-do with that you have updated some library that blender depends on,
and need to create a symlink that has the name of the old version of the lib pointing to the new one.

Like I said, nothing really seemed appropriate in the support forums either, sorry…

Anyway, I just figured it out.
I had compiled with BF_DEBUG=True to get a backtrace and this is what I got:

#0  0x08710ca5 in get_viewedit_datamask () at source/blender/blenkernel/intern/DerivedMesh.c:2003
#1  0x082d774d in count_object (ob=0xa780790, sel=1, totob=1) at source/blender/src/edit.c:583
#2  0x082d86b7 in countall () at source/blender/src/edit.c:846
#3  0x081c572b in setscreen (sc=0xa76e968) at source/blender/src/editscreen.c:2382
#4  0x08770f61 in setup_app_data (bfd=0xa76a168, filename=0xbf9b03f0 "/home/dreblen/.B.blend") at source/blender/blenkernel/intern/blender.c:396
#5  0x087711bd in BKE_read_file (dir=0xbf9b03f0 "/home/dreblen/.B.blend", type_r=0x0) at source/blender/blenkernel/intern/blender.c:461
#6  0x0833fba2 in BIF_read_homefile (from_memory=0) at source/blender/src/usiblender.c:666
#7  0x08340cb0 in BIF_init () at source/blender/src/usiblender.c:1079
#8  0x0819ad87 in main (argc=1, argv=0xbf9b0744) at source/creator/creator.c:536

So I deleted my .B.blend and it fixed the problem.
I guess it got corrupted somehow? Oh well, it’s fixed now…