[SOLVED] Blender won't play animations

Hi everyone, I’m new to Blender and the forums, I’m sorry if this has been answered already, I don’t know how to look it up and whatever I looked up didn’t help me solve my issue.

I made some animations for a rigged Blender model following a tutorial by Sebastian Lague.T hese include idle, walk and run animations, which work in Blender and Unity.
However, when I came back after a few days to make a new animation, attack, after creating the new animation and inserting it’s keyframes in the Action Editor, the animation wouldn’t play.


I noticed the animation from which I created the new action was still present in the NLA editor

Deleting this animation in the stash and trying to move the animation cursor still does nothing. Did I do something wrong?

What am I missing?

Thanks in advance for your help.

Update: Fixed it by pickink LocRotScale as active keyframe at the bottom of the screen.

could you please share your file?

If you are trying to get the walk to play, then you need to unmute it in the NLA. Press the speaker icon. When you mute it like you have it won’t play.

If I pick the walk animation from the action editor it plays, any new animation doesn’t, as shown in the gif.

Put a blend in and both actions and I’ll look at it. Post it here http://pasteall.org/blend/ and give me the URL. Also please include how you are doing this or what you can’t play. I’ll get you going.


There’s the .blend file. There are 4 animations: idle, walk, run, and attack. Attack is the new one and the only one I can’t edit.

As all other animation I did, I created a new Action, moved the rig to the position I wanted then I over the 3D view I hit A to select all the bones and I to add a keyframe with the bones’ new position to the action editor.

Update: Fixed it. Had to pick LocRotScale as active keyset. I can’t believe it took me a whole day to figure that out. I am sorry for making you waste your time.

Yes you keyed scale only. You can look at it by selecting your bone. Then hit the little arrow next to your ghost in the action editor, which then shows only that bone. Expand your channels and you will see the keyframes are all the same. Don’t worry, been there, done that! Also that is what the solid bar means in the action editor or dopesheet. It means keyframes are the same.

For anyone who still has the problem of “animations will not show in viewport”…

I figured out what went wrong after this happened after I rendered the clip. I only needed to render frame 0 since Blender automatically does NOT set the range of your renders from 1-60. So I set the frame range to be from 0 to 0 (the 1st frame only). After the rendering of this single frame was done, it also set the START and END frame to 0,0 in the viewport. That why the animations would not play in the viewport anymore.

Simply changing the range back to 60 (the cycle of the animation) worked to solve this issue for me.

1 Like

That’s simple! Thank you for this hint :heart_hands: