SOLVED -- Edit mode: Strange transparency appearing on a few of my models.


Viewing my model in edit mode via 3d viewport I’m getting some strange transparency showing up towards the outside of the model. How far the transparency cuts into the model varies according to the angle it’s viewed from.

Being that this issue is difficult for me to describe/google, none of the solutions listed in related posts have worked for me.

I made sure limit selection to visible is enabled, and face normals are correct. Other than the default grey material, there are no other materials or textures hooked up.


↑ The model shows up perfectly fine in object mode.

Considering I’m able to select faces, verts and edges that are obstructed by these faces unintentionally turned transparent, I’m guessing this isn’t due to bad gpu drivers.

Specs: Blender 2.69, win 7 64bit, latest hd7850 catalyst drivers.

Any suggestions or help would be greatly appreciated.

For some reason this happens whenever your start clipping value is set way too low. Yours is set at .001 which will cause this to happen. Try turning it up some, and the error should be fixed.

It’s a depth buffer precision issue. It’s expected and not a bug, that’s just how GPUs work. As ItalianJoy said, lowering the clipping range should fix it.

Check if you have scale applied and object’s size is reasonable. I guess i see 0,038 Scale value around. Ctrl-a and it will be 1.
Hopefully problems will go away too.

seen that before !
and if you have inside faces it would show it like that !
so you mesh might need some clean up !

happy bl

Thank you all for the replies, ItalianJoy, Piotr Adamowicz, eppo, and RickyBlender. The issue was virtually completely fixed by turning up the start clip to .05. —.01 (default) still made the fringes of the mesh transparent to some degree.—

The reason why I initially mucked with the start clip was because I felt the need to zoom in really close to the mesh so to more accurately select verts that were within close proximity. Zooming in too close caused the mesh to clip from view which rendered selecting said verts impossible.

In an effort to keep the functionality of being able to zoom in really close without the mesh disappearing, I went with eppos suggestion: I applied the scale in object mode, went back to edit mode, but the issue was the same. I then tried to scale up the mesh first (to more than 10x its original size) before applying scale and the problem persisted. Then I went with the suggestion of the majority and adjusted the start clip and that fixed it. But now, of course, I cant zoom in to the mesh as close as I`d like.

Regardless, thanks again for the help you guys.

RickyBlender, Ive double-checked my mesh quite a bit. The mesh is pretty small, only consisting of 128 faces, so it doesnt take long to check the characteristics of each face (I only checked the normals of each one). Though its possible I dont understand what you mean by inside faces, before checking for them I did ctrl-Lshft-Lalt-M while in edit-mode, with mesh select mode set to vertex (Lctrl+TAB -> vertex) to make sure the mesh is manifold. Would I be wrong to assume that verifying the mesh is manifold guarantees there are no inside faces?

On thing that bothered me was that enabling Mesh Analysis and then toggling between the different Types the color weighting appears quite strange. This mesh was made by grabbing, scaling and extruding - no modifiers were used.

If you’re working on really small things, adjusting the end clip might be more appropriate :slight_smile:

Apologies for the late reply, Piot Adamowicz. The day following the date of your reply I tried adjusting the end clip, but unfortunately saw no difference. I first upped it a lil from the default 1000 to 1001, but saw no difference. I then dropped the hammer and upped it to tens of thousands, like 34000 - yet still saw no difference.

Being the newb I am, perhaps I misunderstood what you meant by adjust…

One thing I just found out though is---- while in perspective mode my model has these probs. If I switch to Ortho, the clipping problem that lead me to post this issue is resolved (note: I zoomed in closer in ortho mode for emphasis).


Basically, in my case, if my model clips, merely pushing numkey 5 (or whatever) to toggle into orthographic fixes the clipping. No matter how close I zoom in to the model it won’t clip with the camera. It appears perfect even if I set the Clip: Start to the lowest(?) value (0.001).

Thanks a lot for the help you guys. As far as I’m concerned this issue is resolved.

In essence, I love ortho - at least for detailing.

Forgive me if I come off as sounding like I did it all by myself. That is not at all my intention.
Thanks to you all I was made more open to different ways of solving a problem, and for that I am truly grateful. Frankly put, while a bit inebriated just now I noticed the mesh appear different in ortho. lol Maybe alcohol is blendable?

I sincerely appreciate your guys’ suggestions. And I apologize for having wasted your time.

All of them just mentioning clip start alone but clip end also matters.

I suffered the same problem when rigging my character. So I too searched for thread. I found something that 1 km in metres.

If you reduce the clip end, it will resolve showing inner vertices of the model.