[SOLVED] Emitter shader antialiasing?

In Cycles i can use AA for Emiter shaders?, Thanks.

Strange question

as far as I know, antialiasing works overall, not per shader.

If you have sharp edges on the highlights it simply means that the strength of the light is so strong that AA can’t smooth the edges. you can simply lower the contrast of you hdri, or use clamp direct to clamp highlights values. But be careful with clamp, not to clamp to much.

This thread mean that you need to modify the emission shader that you have on your lamp.

I don’t have a computer at the moment to make a screenshot, so I’ll try in words.

On your lamp create mix shader, connect existing emission BSDF to the first input of MIX, and another emission BSDF with strength of 1.0 to the second input of MIX shader. Also create the LIGHT PATH node and connect IS CAMERA RAY to the factor of MIX SHADER. That’s it

Thanks, i now understand!!. :slight_smile:
But for what I needed this really served me also this other solution


Thanks for help me ITdreamer !!

Well, the screenshot what you posted is exactly what I was talking about in the first post.

But! According to the strength of your emission shader, which is 1.0 all your sampling and clamping options are pointless.

This has meaning only if your emission shader strength is higher then 1.0.

Also 121 sample for simple masks is too high. 16-32 is enought.

Yes, 16 samples is good cuality and very fast!! thx :smiley:
you are right, i don’t know because i put clamp before.
Clamp is not necessary.

Thanks again for all ITdreamer.