[SOLVED]How to make a "default" action?

Hi,

I’m developing a game but I need to learn to make a “default” action because if you don’t create it , the other actions , for example , walk to the left , continues playing but blocked, I need to make the default action to return , when you don’t press any key , return the mesh to the ORIGINAL POSITION of the armature.

Image Example:

My only question is how to make the “default” action , I have maked it in blender 2.49 , but now , in 2.58 if I set the “default” action to alway mode , when you press for example the walk to the left animation , the “default” action persists.

I repeat , in blender 2.49 this not occurs , but now , YES , this is my problem. Anyone can help me?

Keep working with 2.49, its a great version!
Now, more seriously, if you don’t use python scripts, the behaviour should be the same in both versions?..maybe you’ve changed a little detail?
Bye

I have maked the default action sameless at 2.49 , but 2.58 have changed really a LOT.

Yes , I know 2.49 is a great version , but I prefeer learn more about 2.58 because in some time 2.49 will be a really old version , without all the new caracterists and options that haves 2.58…

I continue with the problem , another person can advice or help me?

You should animate your default pose. it doesn’t need to do anything. Just make sure all armature components are selected and make 1 keyframe.
Now make an always sensor and an action actuator, set the keyframes right and select “loop stop”
it worked for me.

I got this from this blendercookie tutorial:


about 22.20

And I keep repeating myself, the game you’ve made in 2.49 should act the same way in 2.58 ( except if there’s python scripts)!
And I don’t see/get a problem in your file?!
Bye

Are there any errors in the command window (Help menu to enable the window)?

I searched in the help menu… but I don’t view the command window… Please help… fast please! It’s the only problem I have for now… :frowning: and I can’t continue developing my game withouth the default action…

I decided to upload the .blend file to all , if you can help me , the default action is typed in ALWAYS mode. Only see it , and help me to solve it…

Download .blend File | Help meeeee!

Heeelp!! :’(

Among the options in the Action actuator you will see a property called “Priority”. An action actuator with a low number for priority will be prioritized( :stuck_out_tongue: ) over an actuator with a high number for the priority(as odd as that may sound). So if two action actuators are activated at once and one has a priority of 3 the other a priority of 5, the action actuator with 3 will be played.

Hope that helps,
all the best!

Solved! Thanks CrazedQuetzal!