SOLVED!! how to make objects visible in reflections but invisible to camera?

title says it all

i want to have some planes to appear in the raytraced reflections but not get rendered. ,ie,invisible to camera.

I was just about to ask the same question! here’s waiting…

You can use render layers with the objects on one layer and mirrors on another.
Basic example of a cube above a mirrored plane. The cube is invisible to the render but the reflection is visible.
mirror.blend (52.9 KB)

can you explain how here

i tough light where per layer ?

invisible might be too much !

there 's no light on layer 2 and the cube is not illuminated form layer 2 so it’s sort of not being shown in render

but how can the light in layer one sees shadow from layer 2 ?

Thanks

First, thanks.
Second, can you explain a bit more how and why it works?
Whoever wrote that wiki is good at making me feel miserable.

In my example I need to separate out the cube from the reflective panes. This first thing is to put them on separate layers.
In the render settings I set up two render layers. One called Cube which is set to render layer 2 and Mirror set to render layer 1
There is a node system that takes the render layer 1 and outputs it to the composite node. Select Do Composite in the Anim settings to output this composite node.
There is a lamp on layer 1 to illuminate the mirror and the shadow is set to ‘Layer’ so the cude doesn’t cast any shadows. If you unselect that you will have a unpleasent shadow from the invisible cube.

I don’t see a node system in that file.
It gives results without do composite also

but if you add another objects on first layer or second layer it do show up in render
si anyway to make other objects appear and how ?

what is the composite doing ?

i see only one scene and one output ?

so here in layer one from the lamp data it’s only shadow !

Thanks

Also, the lamp is NOT set to layer in that file.
Maybe you have forgotten yourself:)

EDIT: OK, it is.
But the composite thing stays

Hi,

Make sure you’re looking at composite nodes, not material nodes.

yes exactly I’m looking at composite nodes.
not there

Hi,

Strange. I can see it.

Yes but it does give result without composite.

got it.
i finally know how render layers work.
it actually works without the other render layer as well. Just have the mirror one andd delete cube layer.
thanks for help wveryone and marklew.