[Solved] Is this a Bug in Remove Doubles or am I Doing Something Wrong?

I’m trying to limit the number of vertexes to be considered in a remove doubles operation, but somethings not right.

In this picture I have a hard island of mesh that is separated from the main model. In edit mode I select the Hole edge in the main model, then the hard edge I want to attach to it. Vertex counts are the same in both selections and the vertexes aren’t offset by that much. Remove doubles is active.

When I increase the merge distance in the Remove Doubles options, the Hole Edge deselects, the merge does not happen where I expect it to and the merge distance has to be ramped up extremely for the separated vertexes to start welding.

Why does the Hole Selection toggle to deselect? (Bug? or My Process?)
I expected the selection to remain active and only the selected vertexes to be considered as weld points.

To get this to weld properly I have to toggle the Unselected checkbox on.

Blender 2.79b. builddate 2018-3-22 14:10 hash f4dc9f9d68b
Steam Edition

Thanks…

Hmmm, DOH!, I think I found my problem. I did not re-click Remove Doubles after making my second selection.

I was reusing options based on a Remove Doubles operation I did earlier. I had to refresh the options panel for the new selections by clicking the Remove Doubles again after making them.

Sorry if I wasted someone’s time with this…

I’m going to leave this here in case someone else makes this silly mistake and is trying to find out why the process is failing.

1 Like