[SOLVED-ish] Why does rendering an animation crash...

(Why does rendering an animation crash Blender all of a sudden? (with files))


So I’m going into 2d-style animation and rendered out a little test movie last night. Did some more testing today – this time trying out some bone rigging and Blender immediately crashed on clicking ‘render’.

My first thought was that it could have been something in the rig, but my first ‘boneless’ file from last night now seems to have fallen victim to the crash bug too.

Mac OSX 10.6.8
Blender 2.70

Project Files:

Not that I think they make much of a difference because it’s a problem that wasn’t there the same time yesterday with the same file …

Marco :slight_smile:

I just tested the animation and tried rendering it. It worked fine on this end (Windows 7), and I couldn’t spot anything out of the ordinary.

I’d hazard a guess that something else has changed with your computer to cause this. In which case I’d check to see if any other older Blender projects, have the same result (and check if it happens with brand new files too).

Yeah that’s my theory too! If anyone reading this has an idea what it could have been I’d be curious for what you have to say. I know Firefox was running and it has been known to mess with my other programs occasionally, but again, it was open when the animation didn’t crash.

I tried it with Blender 2.72 and it worked fine, but updating to a newer version because something randomly breaks doesn’t strike me as satisfactory.

The animation still crashes 2.7 after restarting the computer and turning off all other programs.

I made a new file based on my 2D template and 'appended or link’ed the objects from my animation and it crashed.

The animation didn’t crash when I appended the animation stuff to my other template (default cube, 3D view and a few materials).

So it’s not the animation but template that broke, but this kind of begs the question…

Sorry, but if your computer resets, most probably it’s not a Blender fault. My bet is that your computer has a hardware failure. Have you tried using a memoty chip test program?

No I mean I restarted the computer (or more specifically turned it off before going to bed and turned it on today) and the problem still extists. :wink:

It appears to be a problem with one specific blender file I made but what exactly it is I can’t tell – it seems it just broke.

A sad thing about Blender is that it doesn’t complain about lack of memory. It simply crashes. How much RAM do you have? Did you add anything that could increase memory usage? At the office, I’m stuck with a 4 GB RAM computer, so it’s quite common for me to render an animation in 720 x 480 with no problem and see the same animation crash at 1920 x 1080.

I tried it with Blender 2.72 and it worked fine, but updating to a newer version because something randomly breaks doesn’t strike me as satisfactory.

It may well have been a bug in 2.70, that has been fixed since. If it works in 2.72, why not just start using that? More fixes, more features!

I don’t think it’s lack of memory – I have 2GB of it and always keep my renders small, 400x300 in this case, sometimes 800x600 if I’m feeling magnanimous haha! :smiley: Anything bigger/better/aimed at a wider audience I’m prepared to render out as jpgs.

After some testing I now believe that a mysterious something irrevocably corrupted the template file I made for 2D purposes – that is, it’s broken in 2.7, 32 Bit and works with 2.72, 64 Bit.

That’s not untrue… I guess it comes down to a need for certainty for me – what if it’s this or that and happens again etc. etc.

But now I’m halfway into 2.72 territory already. 2.7 eat your heart out!