[SOLVED]MakeHuman model faces rendering wrong in BGE.

I’ll post here the same as I posted in MakeHuman forum… because I don’t know if it is a MH or Blender Bug (or what).

As you will read, the model is pretty advanced… so, I don’t want to export again from MH, import again in Blender, make aaaalll the stuff I’ve already done. So, whereever the bug is from, I would want to fix the model/mesh/whatever to make it looks correctly.

>
Software versions, OS, 3d card:

  • MakeHuman 1.0.2
  • Ubuntu 14.04 64x
  • Nvidia GT620
  • Blender 2.74 stable version.

I’ll try to remember what I did with this character:

  • I did the model in MH.
  • I exported the model to “Blender exchange (mhx)” as it is in Export settings. No rigs.
  • I imported in Blender using “Import: MakeHuman (.mhx)” addon, by Thomas Larsson, Version 1…1.6…1.2
  • I modified the mesh to have “T” pose and some other deformations.
  • I scale to my preferred size. Applied the scale. It dimensions are: X 1.612367m, Y 24.182149cm, Z 1.612817m.
  • I use “Transfer Weights” from another model.
  • I parented the model to a rig that I had (now, it has one modifier: Armature).
  • I made a lot of shapekeys and drivers.

The character, as seen on Blender View3D:


When I enter in Game Engine:


As you can see, some faces from the inside of the mouth, the eyes cavities and ears, appear in front of other faces… and they should be hidden.

I don’t understand why it is like this and how should I fix it.

PD: I remember that I have a similar problem, about 6 years ago, with a very old version of Blender (no MakeHuman, only Blender)… but it was fixed in newer version (you can see a screenshot in http://pasteall.org/pic/89930, not to flood this thread).

Delete any irrellevent crap from the blend but it still show the problem, save the file and supply a link to it

Go over your human materials and disable transparency for them.

Thank you for the fast response.

I just imported the same model (.mhx) in Blender again and enter in Game Engine, the artifacts are there.


I deleted all the materials, and it looks Ok (but with no materials):


So, I discovered that is was about materials/textures… it was about Transparency. The materials were transparent, with Z Transparency to 0 and the Texture Alpha channel checked. Right now, I don’t know why it looked like that anyway… but my problem is solved. If I discover that it is a Blender Bug, I’ll report it and advice here. Here is the model correctly rendered (skin and hair with no-transparency):


EDIT: @adriansnetlis, I posted this before seeing your answer! You already had the solution…