[solved] Materials look fine in preview/render but distort in GE

I’ve got a simple model that shows fine in the 3d window, in the preview (shift+P) and in renders, but the moment I push “P” in the game engine the textures go something like below.

I’m using “Use Blender Materials” and have searched for tutorials on texturing specifically for the game engine, but haven’t managed to find any so far.

If anyone has any idea how to fix this, or of a good tutorial to learn the differences between blender materials and blender game engine materials I’d love to hear about it!

You can see the .blend file at the direct download link here.

Thanks!

Attachments


Hello again
you must use the UV editor
a little tut ( quite old):
http://otothecleaner.free.fr/tutorials/LittleOTO/littleoto4/otolittle4.html

more recent:
http://otothecleaner.free.fr/tutorials/LevelDesign2/level1/level2-1.html
Bye

yea, and then twoside I think
Uv face select > (in other screen) go to editing (F9), then search for Twoside button and press) works only with one face at a time

OK thanks for the suggestions.

Nice tutorial, too OTO! Tres bien, merci beaucoup!

The mesh does actually have UV’s already and the textures show fine in the 3d view. The mesh is also double sided already, too if that’s what you meant? (F9 -> “Double Sided” under Mesh).

Any other ideas? :smiley:

Hello
quick solving:
select each object and delete the material
Now the UV textures should appear…but you’re working the wrong way
?!
Bye

Hi
I have managed to show your textures in the GE
for each of the materials you use, go to the F5 panel, and in the Map input choose UV instead of Orco. (and do this for all your materials).

I hope it helps, otherwise I could send your file with the changes.

concerning your robot’s teeth, you did not make any UV unwrapping, apparently, and you should see in the Shift+P preview that there are more teeth displayed (the texture is less stretched) than in the GE display. I would not know how to explain that, chances are that the conversion of materials to the GE does not translate texture mapping sizes perfectly.

Also now with UV enabled for many of your materials, the normal Blender rendering is messed up for the stomach… I don’t know if this is something you care about. I’m sorry because I’m too lazy to look further into that problem.

*The mesh does actually have UV’s already and the textures show fine in the 3d view. The mesh is also double sided already, too if that’s what you meant? (F9 -> “Double Sided” under Mesh).

Its called twoside -.- xD

editeted
know wait, I ment twoside, its a little more to the right :slight_smile:
(texture face)

or:


| if youve add a colour to your robot, you must go to texture with F6, add texture, press F5, then under map input on ther right,

click UV.

Woo Hoo! All fixed. :smiley:

Thanks everyone for your help with this. Turns out that the problem was a bit of a mix of needing the Orco changed to UV option combined with using multiple materials. This is why choosing UV for the body didn’t fix the stomach as it was a second material applied to the mesh. When I went and applied UV to the second mesh material, too everything went perfect.

All is good, and thanks again. :slight_smile: