[solved] NLA: problem with blending out of lower strip

hello,
yesterday I give a try to NLA editor but I was knocked down with problem of blending between strips, and I don’t know how to correct it.

ok, what’s going on:
there is two strips, upper and lower… lower strip is waveing action which I set for blend out, blending seems nice, arm is going low from waveing at the near end of this lower strip (see frame 95), but in last frame of lower strip arm is strike upward (see frame 96), and later the arm moves by upper strip (see frame 97)… so the one problematic frame is frame 96, there is a end of lower strip, but it seems the armature is not doing right with merge of blended out lower strip and continuous upper strip…
please, how can I repair/correct this blending?
look at the screenshots from viewport and NLA editor (focus your attention on armature, not mesh… I don’t know why, but mesh is delayed in movement related to armature movement… maybe some kind of problem with skinning or that’s the way how it worked?)

animation: http://uploader.polorix.net//files/630/test030001_0200.mov
screenshots:

http://uploader.polorix.net//files/630/probs_anim/frame95.JPG

http://uploader.polorix.net//files/630/probs_anim/frame96.JPG

http://uploader.polorix.net//files/630/probs_anim/frame97.JPG

any suggestion please? :confused:

Click Hold. http://wiki.blender.org/index.php/Manual/Non_Linear_Animation#Properties

PapaSmurf: thanks for advice, but when I press hold for lower strip, hand will remain rised forever (until some lowest strip override it)… so it’s not working…
but I find (lol, “very hard” finding) a solution - I just move lower strip for some 0.xy frames left/righ (I don’t remember, but it doesn’t matter) and this problem dissapear (I don’t really understand why, cause I try to move strip left right as a first thing which come to my mind)
so now I’m happy and ready for some NLA messing :smiley: