[Solved] Object Tracking - Constraint to f-curves not working

Has anyone had problems with converting a motion tracking camera or object constraint to f-curves recently? When I use the ‘Constraint to F-Curve’ it creates only a small number of keyframes (sometimes just one). Perhaps I’m missing something? Is there a way to specify the frame range over which the f-curves are created?

It hasn’t worked for me in the last several versions (2.68, 2.69 64 bit windows). I’m wondering whether to report it as a bug, but want to check if I’m doing something wrong first.

I realise this is 6 years late but the same problem frustrated me. Apparently, if you want ‘constraint to f curve’ to work for a tracked object, you need to track your camera as well and give it a camera solver constraint, then hit the button on your object constraint. That’s it.

Wow, thanks! I never did work that out, just worked around it.

Thanks for posting an answer - it’s frustrating to search for an issue and just find an unanswered question.