[Solved] Quick question on blender texture painting in 3D viewport..

You can call me lazy, but quickly I am unable to find out more, maybe I lack the correct search terms.

We´r in 2.49 for my question.

Having one object with multiple materials, each with a UV map for texturing large objects, it works perfectly to paint on it in the 3D viewport, as well as directly on the texture, the problem is, painting the texture directly, I can´t paint over the seams between the textures, which I can do when painting in the 3D viewport.
However, I want to use texture brushes. I can perfectly choose whatever texture I like as brush to paint in the uv texture view.

Here goes the question:

Is it not possible to paint with a texture brush in the 3D viewport in 2.49 or am I missing something?
Is it possible in 2.5 if it is not in 2.49 as it is considered a lack of a feature? =)

Might be a stupid and answered question, or even a much discussed topic… sadly I had to time to seriously dig into 2.5 as I am totally swamped with work and the last projects basically trapped me in 2.49 =)


I hope I understood your question right.

In ‘Texture Paint’ mode you get the paint panel in the Editng panel (F9).

There you can set all the brush properties. What may not immediately be obvious is that you can add a texture to be used for the brush. It’s the button/drop down ‘Add New’ which will add a new texture data block, which can be edited in the texture panel (f6) and selecting type Brush there.

I have attached a screenshot which highlights the texture add button. I hope this answers your question.


You got it wrong =)
Nevertheless… it works as I wanted it to work.

But I am sure the screenshot + google search will help others just fine having the problem setting a brush at all… =)

To clear it… I know where to set the Brush for texture painting just fine. My problem was, the brush only worked in the UV/Image editor window, not in the 3D viewport.
In the 3D viewport it just used the set color when I painted, In the UV/Image editor it used the brush I set.

For reasons beyond my understanding, why it did not work in the last attempt, it just works fine now.

When I set the brush texture in the UV/Image editor, it is set, and also works in the 3D viewport… as I expected it to work…
Thats Blender: 4325, User: ZERO :smiley:

see my second sig =)