[SOLVED] Render preview differs from material preview

Hi everyone,

I’m going nuts on this problem. I made my way through the node setup to get the texture result I want. In the material preview it’s shown the right way:

When I render it the “Sagwey” logo (I know it’s not correct - for good reson ;)) is not shown. I spend hours to find a solution but no luck. As I’m no nodes pro I hope someone of you sees where my mistake is. This is the node setup:

I’m happy for every hint.


Blend file please? Make sure that you pack all your images: http://wiki.blender.org/index.php/Doc:2.6/Manual/Textures/Mapping/UV/Applying_Image (bottom of page).
You might want to consider using dedicated UV nodes for each of your images instead of using the ‘texture coordinate’ node and no input for one of your textures. Also, when using multiple UVs, the viewport previews can get a little weird, because for some reason, it applies the visible UV to the mapping of all the textures.

You can download the file via the wetransfer link. Hope I did it the right way. Have never packed images :eyebrowlift: I really hope you have a suggestion.


very nice … gode node … good render :yes::yes::smiley:

As Benjamin already suspected, you have been using the wrong UV map for the logo. You didn’t specify any, so Blender used the visible one for the “Material” view, which was not the one Cycles used for rendering.

I just changed the Texture mapping node for an Attribute node with the correct UV map (Interior) and lo and behold - the logo shows up:

Oh boy…I tried it with the wrong attribute. Embarrassing that you guys work better with my setup than I do :o

You made my day. Tanks!

If you could, would ya go and change the prefix on the title of this post so it says [SOLVED]? Thanks!